Results 1 to 9 of 9

Thread: 1990 Mighty Max/s m Issues w/ Shift Linkage

  1. #1

    Array
    Status
    Offline
    Join Date
    08-10-2020
    Posts
    6
    Location

    Augusta GA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    I.D.K.?

    1990 Mighty Max/s m Issues w/ Shift Linkage

    Hello, i have a 1990 Might Max extended cab, i just bought it anyways, the guy that i bought it from told me that the linkage under the steering column & dash wasnt set exactly right. Its an automatic, btw, anyways it cranked fine until a couple days ago but now it wont turn over in park, i have to place it in neutral, also it just over but wont start. Almost like its not getting spark. I changed the rotor button and fixing to change plugs & wires.
    Could someone please explain to me how to set the linkage, and suggest what else could be causing the starting issues? I do know its not the timing.
    Thank you!

  2. #2

    Array
    Status
    Offline
    Join Date
    12-23-2012
    Posts
    3
    Location

    Lexington NC
    Vehicle

    1992 Mitsubishi Mighty Max
    Engine

    4G64
    I had a similar problem with my 1992 model. It is an automatic extended cab. Have you checked the linkages underneath the truck on the transmission? I found that the plastic guides for the metal linkage rods were brittle and falling apart. One was already completely gone. I had to go to advance auto parts to the HELP parts section and find some new pieces that I could make work. Just a suggestion. This fixed the problem with mine. It was doing the same thing.

  3. #3



    Array
    Status
    Offline
    Join Date
    03-06-2018
    Posts
    61
    Location

    Tucson, AZ USA
    Vehicle

    1987 Dodge Ram 50
    Engine

    G54B
    Sounds like it could be the neutral safety switch? That won't let you start unless you're in Park or Neutral, so it could be misaligned or getting dodgy.
    1987 Dodge Ram 50 4G54 2WD longbed ("Elmo")
    1979 Lancia Beta Zagato spider ("Lola")

  4. #4

    Array
    Status
    Offline
    Join Date
    12-13-2014
    Posts
    161
    Location

    redding ca
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    yep, neutral safety switch. i had a similar issue with my 1990. i cant remember at the moment how i fixed it but i remember it being pretty easy.

  5. #5

    Array
    Status
    Offline
    Join Date
    08-10-2020
    Posts
    6
    Location

    Augusta GA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    I.D.K.?
    Well i know that the linkage isnt set correctly because the person i bought it from told me that he worked on it and the plastic retainer broke off. I fixed that isdue, but like i said not no accelerating but at driving speeds it wants to act like it needs to shift. I can feel & hear it shift when im accelerating like its suppose to do, but lets say i reach 45mph, or higher, it like its pulling back or needs to shift like its in 2nd and needs to change to 3rd type thing. It will start like its hiccupping but when i give it gas it stops and works fine until its at a steady speed again. What is this issue & how to fix it. I also noticed that if i go like l want to pass simeone it doesnt kickdown into a passung gear just stays in the gear its in.

  6. #6

    Array
    Status
    Offline
    Join Date
    08-10-2020
    Posts
    6
    Location

    Augusta GA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    I.D.K.?
    By the way could the linkage not being set properly cause this issue?

  7. #7



    Array
    Status
    Offline
    Join Date
    03-06-2018
    Posts
    61
    Location

    Tucson, AZ USA
    Vehicle

    1987 Dodge Ram 50
    Engine

    G54B
    Sounds like you're actually in 2nd when you think it's in D.
    1987 Dodge Ram 50 4G54 2WD longbed ("Elmo")
    1979 Lancia Beta Zagato spider ("Lola")

  8. #8

    Array
    Status
    Offline
    Join Date
    09-26-2014
    Posts
    420
    Location

    Ca
    Vehicle

    1993 Dodge Ram 50
    Engine

    4G64
    2x4? 4x4? 4g64 or 6g72 ?
    thx

  9. #9

    Array
    Status
    Offline
    Join Date
    12-13-2014
    Posts
    161
    Location

    redding ca
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    before my automatic went out, it would act like its jumping in and out of gears. yours is probably due for a band adjustment. if you are over 75,000 miles than its definitely due for one. fwiw my tranny died at 105,000 miles. these trannys are based on a Chrysler a500 and use the same maintenance intervals. i ripped mine out and tossed a manuel in.

    so get a band adjustment done and see how it drives. also get the kickdown cable adjusted. ive done some looking but cant drrm to fine the procedure right now. will update once i have it.

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •