Results 1 to 2 of 2

Thread: Wire harness swap. Need help

  1. #1

    Array
    Status
    Offline
    Join Date
    07-31-2020
    Posts
    1
    Location

    Hilo, Hawaii
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15

    Wire harness swap. Need help

    Need some help Gang. Have a 1990 max, and wire harness was chopped up from previous owner. No internal or external lights. Starter hooked up to push button and fuel pump converter to front. With a electric one. Well hot it to run just by putting in new starter. I swapped harness with new one from a D50. Having problems with it turning on. No power. Any tips can help. Thanks Aloha [Aaron]

  2. #2

    Array
    Status
    Offline
    Join Date
    06-15-2014
    Posts
    4,996
    Location

    Adelaide, South Australia
    Vehicle

    1985 Mitsubishi L200
    Engine

    G63B
    Hi and welcome to mightyram. What engine/transmission combo is your truck running? And I think part of the issue is swapping a harness in from a Gen 1 truck. They are a lot more 'rudimentary' compared to a Gen 2. More than likely you have a lot of dead ends and open circuits that are disabling the lighting systems. If you can post a pic or 2 they sometimes help with visually identifying an issue.
    support the forum that supports you - join and donate to MightyRam50.Net today! donations unlock the edit function

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •