Page 4 of 4 FirstFirst ... 234
Results 76 to 82 of 82

Thread: My new (old) 1992 Mitsubushi Mighty Max

  1. #76

    Array
    Status
    Offline
    Join Date
    07-07-2019
    Posts
    74
    Location

    Central Texas
    Vehicle

    1992 Mitsubishi Mighty Max
    Engine

    4G64
    Heyall,

    I been gone again for a while. too much "stuff" happening in life nowadays. Cant even say anymore that I can fill my tank for 20 dollars or so. The whole 10 gallons I burn costs over 40 now ><. Still beats what the wife has to pay for her "full fill". It was nice to cruize 50-55 to work now without all the lights and turns and doing just under 30 miles / gallon. Wish I could do an electrical swap now. Been thinking about that for a while. The kits for it are out there.

    But as usual, still having issues. Now I getting high idle. False vacuum somewhere probably, not been able to find it yet.
    Hope I can find enough time and funds to work on this and get Macro usable again.

    Fushy.

  2. #77

    Array
    Status
    Offline
    Join Date
    06-15-2014
    Posts
    6,059
    Location

    Adelaide, South Australia
    Vehicle

    1985 Mitsubishi L200
    Engine

    G63B
    Cost of living is getting out of hand. And fuel prices are a killer. Your IACV may be gummed up and causing a bypass into the intake. Good to see you are still joining the fray so to speak
    support the forum that supports you - join and donate to MightyRam50.Net today! donations unlock the edit function

  3. #78

    Array
    Status
    Offline
    Join Date
    07-07-2019
    Posts
    74
    Location

    Central Texas
    Vehicle

    1992 Mitsubishi Mighty Max
    Engine

    4G64
    Heya all,

    I have not quite figured the high idle out yet. I did something and for the life of me I do not remember what but its less now.
    She still running and taking me to work and such.
    I did finally get me ass in gear and fixed my driver side of the bench. The steel rods on the springs broke and I have been sitting on the floor board for over a year now. Sure makes the little pick-up feel like its sitting higher on the roads now lol.

    Had some interesting storms here before the heat settled in in Texas.

    Tree in the drive way lost its top ( good thing it did not take the power lines with it ) and fell on Single and the wife her car. No damage to either vehicle other then saw dust and such after I sawed my way through.


    With Macro still parked in the back and this heat wave going through I am not doing a whole lot.
    I did get to measure the actual radiator temp after yet again having done something I do not remember. Temp at the radiator entry is the same as the thermostat temp that I installed. So all good there. Cluster gauge is also not as high anymore as it was and only reaches the same is half way it did in the winter before at the heat of the day but stays around a little over 1/4 in the morning now.

    I am still alive and kicking out here. Hope you all are as well out there safely driving around in these little monsters!

    Fushy.
    Attached Images

  4. #79

    Array
    Status
    Offline
    Join Date
    07-07-2019
    Posts
    74
    Location

    Central Texas
    Vehicle

    1992 Mitsubishi Mighty Max
    Engine

    4G64
    I really have not posted anything for nearly a year now. Time is passing me by too fast and sure makes me feel like I am getting nothing done anymore.
    Single still runs and takes me places. Though currently with the heat I am also driving the other one.
    Found part any maybe cause of the high idle. Seems to happen only when the purge valve opens and if would seem that one of the hoses under the tank or the filler neck is the actual leaker. Not been in the mood lately to pull the tank again to find the holly hose. Smaller tank and easier to pull then the Macro but still. Too lazy I guess and glad also its not the tank under the wife's Ford. That thing has too many hoses and electrical sensors and stuff on the harnass near the pump.

    I have seen others with issues ordering clutch cables in them being too long. Right now I have the new cable ( I snapped mine again ) attached to the first bolt on the hook plate at the transmission.
    Previous owner had the transmission redone and also put new clutch on it. Clutch with too strong springs on it so I ripped the firewall. Gots a nice hole in there now. I bent back what I could and re-inforced the whole area. Inside the cab there now is a metal place with a hole big enough for the cable and the original presser holder to stay put. In the engine compartment I placed a metal bar at the top that sits just under teh break booster.
    Break booster has some very nice inforcements around it. Wish they did this around the clutch cable hole also. Below the clutch hole is an other metal place and its all bolted together. Put some 5k or more miles on this work now and its still holding.

    Is there anyone that knows what the actual length of these cables is supposed to be for these pick-ups?
    Also is there anyone that had converted over from cable to hydrolic. I was able to find several parts that could possibly do this but the transmission part seems different.

  5. #80


    Array
    Status
    Offline
    Join Date
    05-01-2018
    Posts
    1,453
    Location

    Kailua, HI
    Vehicle

    1986 Dodge Power Ram 50
    Engine

    G54B
    Hello Fushy
    My clutch cable broke about 1 1/2 years ago ordered the Rock Auto 4x4 replacement compared its length looked same but it ain't as good as the original COZ there is no flat washer for the star adjuster ring to push against NOW the star ajuster pushes against the firewall rubber gromment which seems to undue the adjustment ~ I gotta keep readjusting tighter to keep from grinding gears ~ channel lock pliers can reach the adjuster so I keep them in the truck ANYWAY something aint right with these aftermarket clutch cables LENGTH problem maybe ~ I am aware there are two different lengths RWD & 4WD

    Take care in Texas Bro
    George

  6. #81

    Array
    Status
    Offline
    Join Date
    07-07-2019
    Posts
    74
    Location

    Central Texas
    Vehicle

    1992 Mitsubishi Mighty Max
    Engine

    4G64
    Welcomen back to the never ending trouble.
    I did find something positive with it though so not all bad. Single is sort of stranded in the drive way again.
    What seemed like a nasty oil leak at first when I Was at work. Proved to be a coolant leak when I got home and put the endoscope between the engine and the firewall. Not that its any better but this would seem easier to fix. Well sort of in the short way ot saying it. Replace plug with new one leak fixed.
    On paper yeas. The expantion plug ( of freeze plug ) is done for and there is about 2~3 inches of space to pull it out and press a new one is. Not quite as easy anymore now. I checked the other pick-up and its leaking there also so I will have to replace them on both.
    Does anyone here know where all these plugs are on these engines?
    For obvious reasons I know of one . I remember somehting from twin cam head replacements that there is an other in the front behind the timing covers and I think I saw one near the starter motpr somewhere.
    Rock auto sells a kit that has 9 ( nine ) of them in it. Do these engines really have 9??
    Shop manuals do not show there locations at all.
    No idea yet either if I can replace the rear one with a simple rubber bolt on one yet either.

    Thx ya all :D

  7. #82

    Array
    Status
    Offline
    Join Date
    07-07-2019
    Posts
    74
    Location

    Central Texas
    Vehicle

    1992 Mitsubishi Mighty Max
    Engine

    4G64
    Well, I guess there is a good comparison here for what is happening around me and has been for a while now. "There are no happy ever afters, just new battles." Miss Connally Dock worker guild rep. Babylon 5 season 1 episode 12.
    Sure would be nice to have better preparations for some of these "battles" though. Taking the rest of the week off to figure out what to do. Both gals stranded. One with coolant issues and the other with susspension. Aside from that I also have other issues at hand in and around the house. Wonder what that movie was where the husband cloned himself to get all the work done. Kind of feel like I need an other dozen or so of myself about now.

Page 4 of 4 FirstFirst ... 234

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •