Results 1 to 7 of 7

Thread: Starting and running issues, weather depending!

  1. #1

    Array
    Status
    Offline
    Join Date
    03-13-2019
    Posts
    8
    Location

    Kansas City MO
    Vehicle

    1991 Dodge Ram 50
    Engine

    4G64

    Starting and running issues, weather depending!

    Click image for larger version. 

Name:	IMG_2930.jpg 
Views:	30 
Size:	191.9 KB 
ID:	22430Click image for larger version. 

Name:	IMG_2930.jpg 
Views:	30 
Size:	191.9 KB 
ID:	22430Click image for larger version. 

Name:	IMG_2930.jpg 
Views:	30 
Size:	191.9 KB 
ID:	22430
    I'm lucky to have two problem childs! Red one is my main driver. Starts but won't run good in wet weather. Dies at stoplights unless I hold brake and rev. Starts and runs great in dry weather. New cap+rotor, wires, plugs... mechanic said they cleaned the mass airflow sensor... is that even a component of this truck? 91 Ram50 4G64.
    Gray one started good and died 12 times as I drove it across town. Had to keep it revved. Now it's parked across town cuz after sitting over there a few hours it decided to click but not start anymore. Has new battery. Don't know much else about it b/c I just bought it. I wiggled all the wires a bunch to try to get it to start up again but no dice.
    Advice would be appreciated. I started reading a bunch of the tuning forum, not trying to waste people's time, but I want to start somewhere. Yes they both have at least half full gas tanks. TIA y'all

  2. #2

    Array
    Status
    Offline
    Join Date
    01-11-2019
    Posts
    252
    Location

    Newburgh, NY
    Vehicle

    1987 Dodge Power Ram 50
    Engine

    G54B
    This is probably a silly thought, and most likely not the issue, but throwing it out there because you never know...(and it happened to me).

    Any chance the gray one has an automatic transmission? Mine does, and I accidentally shut the engine off with the gear selector on N or R, don't remember. Then went to start up and same thing happened, it clicked and dash lights went on, but starter motor wouldn't turn. I checked everything, it took me a while to realize it was in gear, because that the last place I thought to look at, but then I did and put in Park, started right away.

    Hopefully that's it!

  3. #3

    Array
    Status
    Offline
    Join Date
    03-13-2019
    Posts
    8
    Location

    Kansas City MO
    Vehicle

    1991 Dodge Ram 50
    Engine

    4G64
    This is a really good thought, because yeah it's an automatic and the gearshifter is kind of janky. I did move the gearshifter back and forth, but with this thought in mind, I'll try to CONVINCE the truck it's in park

  4. #4

    Array
    Status
    Offline
    Join Date
    03-16-2018
    Posts
    274
    Location

    Raymond New Hampshire, USA
    Vehicle

    1989 Dodge Ram 50
    Engine

    G54B
    Occasionally I have to shift down into any gear and send the shifter back to park for the safety switch. Also can try starting it in neutral. Check your coil, the often ignored part of the ignition system. Dirt across the top of the terminals will conduct electricity, and better when it's wet. Coils start to fail internally and will usually get worse with heat. Low voltage to a coil from a failing ballast resistor, or a failing icm are also possible causes.

  5. #5

    Array
    Status
    Offline
    Join Date
    03-13-2019
    Posts
    8
    Location

    Kansas City MO
    Vehicle

    1991 Dodge Ram 50
    Engine

    4G64
    I went over to tow it home but of course it started right up and drove the 4.5 miles home without even dying once! It's kind of a junker really- I'm thinking of parting it out. Glad to just have it back home in the driveway! Thanks for the help y'all! I'll post up the exact engine and components here first for those who would like parts.

  6. #6

    Array
    Status
    Offline
    Join Date
    03-13-2019
    Posts
    8
    Location

    Kansas City MO
    Vehicle

    1991 Dodge Ram 50
    Engine

    4G64
    Also got the red truck running right. Life is good!

  7. #7



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,630
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    A big thank you to SubGothius for spotting the spammer. Upgrade given.

    Spammer gone. It has been a long time since someone actually posted.
    It was a guy from fiver. com that was paid to post crap.
    He was out of Bangladesh.
    So another Bangladeshie is out of a job. HAHAHAH.


    Click image for larger version. 

Name:	zzzzzz.jpg 
Views:	40 
Size:	126.4 KB 
ID:	22549
    Members come and members go, But the board keeps track of them.
    Find me on FaceBook
    clicking HERE.

    Or look on YouTube Click Here.

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •