Results 1 to 14 of 14

Thread: Oil pressure

  1. #1

    Array
    Status
    Offline
    Join Date
    06-01-2016
    Posts
    84
    Location

    Grand Forks BC
    Vehicle

    1985 Dodge Ram 50
    Engine

    I.D.K.?

    Oil pressure

    Rebuilt a 2.6 and truck is running excellent. Having a oil pressure issue with the sending unit I think. At first I put a oil sending unit on for a dash light that did not work with my oil pressure gauge. Sent away for what is supposed to be the proper oil sending unit for a gauge, after installing and starting the engine the gauge needle moves normally but passes mid range on the gauge where it used to be around, continuing all the way right to the end of the gauge and stays there. Any advice. Will check oil pressure with a manual gauge when I get proper fittings.

  2. #2




    Array
    Status
    Offline
    Join Date
    03-20-2011
    Posts
    4,526
    Location

    Pittsburgh, PA
    Vehicle

    1980 Dodge D-50
    Engine

    G54B
    that sounds like an oil pressure switch - grounds out with pressure on it. The sending unit is rather large compared to a pressure switch. That would work kind of for an oil safety pressure switch for an electric fuel pump, except at startup.
    Pennyman1
    The best Dodge that Dodge never made
    Living the D-50 lifestyle since 1980

  3. #3

    Array
    Status
    Offline
    Join Date
    06-01-2016
    Posts
    84
    Location

    Grand Forks BC
    Vehicle

    1985 Dodge Ram 50
    Engine

    I.D.K.?
    Quote Originally Posted by pennyman1 View Post
    that sounds like an oil pressure switch - grounds out with pressure on it. The sending unit is rather large compared to a pressure switch. That would work kind of for an oil safety pressure switch for an electric fuel pump, except at startup.


    Yes i think i managed to order the wrong one. Sending it back and ordering a

    [top]Engine Oil Pressure Switch-VIN: K Beck/Arnley 201-0551


  4. #4

    Array
    Status
    Offline
    Join Date
    06-01-2016
    Posts
    84
    Location

    Grand Forks BC
    Vehicle

    1985 Dodge Ram 50
    Engine

    I.D.K.?
    So I installed a proper sending unit and my oil pressure barely moved the needle on my gauge, so on the advice of brother in law the mechanic I bought a mechanical gauge. I just installed it and on start up 80lbs. Fluctuates up to 100psi, in up to fourth gear. Gauge only goes to100lbs so might replace. But is 80lbs good or bad at idle, or a better question is what should idle and operating pressures be? Thanks.

  5. #5

    Array
    Status
    Offline
    Join Date
    03-16-2018
    Posts
    130
    Location

    Raymond New Hampshire, USA
    Vehicle

    1989 Dodge Ram 50
    Engine

    G54B
    I removed the balance shafts in my 2.6. Cold I see 80-100psi at idle. 25 psi at idle when hot (My idle is pretty low) and cruising down the highway at about 2800 rpm I see about 80 psi. It will climb up to about 100 if I let her rev out. I believe the bypass kicks in at 100psi. The rule of thumb I have always known is that you want at least 10psi for every 1K rpm.
    I run 10-30 oil, although last winter I dropped down to 5-30. We had plenty of below 0 deg. F nights, takes an alarming amount of time to build pressure when oil is about as fluid as molasses.

  6. #6

    Array
    Status
    Offline
    Join Date
    11-29-2015
    Posts
    184
    Location

    miami, fl
    Vehicle

    1991 Dodge D-50
    Engine

    4G64
    can't remember if its all or some year 2.6 starions had an upgraded(forklift?) pump, so they had even more pressure
    To the point where more than a few cars burst aftermarket filters, on cold start. Blew out non-mitsu turbo seals also
    The culprit was a stuck oil pressure relief valve
    eliminating balance shafts increase the pressure even more. Most did

  7. #7

    Array
    Status
    Offline
    Join Date
    06-01-2016
    Posts
    84
    Location

    Grand Forks BC
    Vehicle

    1985 Dodge Ram 50
    Engine

    I.D.K.?
    I don't know when i used the mechanical gauge oil pressure was up around 80-100 lbs. When i put the old sending unit back on (i found it) I know have oil pressure registering below where the numbers start on the dash gauge. It does move but barely, no where near where it used to read before the rebuild. . I'm going to try cleaning the two engine grounds and check the resistance to the gauge and see if thats my problem . I have little doubt I have good oil pressure its running like a top since my rebuild.

  8. #8




    Array
    Status
    Offline
    Join Date
    03-20-2011
    Posts
    4,526
    Location

    Pittsburgh, PA
    Vehicle

    1980 Dodge D-50
    Engine

    G54B
    Soak the sending unit in a degreaser or charcoal lighter fluid - the small hole in the sending unit can clog up from sludge in the oil.
    Pennyman1
    The best Dodge that Dodge never made
    Living the D-50 lifestyle since 1980

  9. #9

    Array
    Status
    Offline
    Join Date
    06-01-2016
    Posts
    84
    Location

    Grand Forks BC
    Vehicle

    1985 Dodge Ram 50
    Engine

    I.D.K.?
    Quote Originally Posted by pennyman1 View Post
    Soak the sending unit in a degreaser or charcoal lighter fluid - the small hole in the sending unit can clog up from sludge in the oil.


    Thanks Pennyman I'll try the soak overnight and see if that helps. Great idea.

  10. #10




    Array
    Status
    Offline
    Join Date
    03-20-2011
    Posts
    4,526
    Location

    Pittsburgh, PA
    Vehicle

    1980 Dodge D-50
    Engine

    G54B
    also run a paper clip in and out of the hole gently to ensure the sending unit is clear.
    Pennyman1
    The best Dodge that Dodge never made
    Living the D-50 lifestyle since 1980

  11. #11

    Array
    Status
    Offline
    Join Date
    06-01-2016
    Posts
    84
    Location

    Grand Forks BC
    Vehicle

    1985 Dodge Ram 50
    Engine

    I.D.K.?
    Quote Originally Posted by pennyman1 View Post
    also run a paper clip in and out of the hole gently to ensure the sending unit is clear.


    Getting on it today. Thank you.

  12. #12

    Array
    Status
    Offline
    Join Date
    06-01-2016
    Posts
    84
    Location

    Grand Forks BC
    Vehicle

    1985 Dodge Ram 50
    Engine

    I.D.K.?
    Well tried cleaning up old pressure gauge sending unit, and same old very low pressure. So installed manual oil pressure gauge changed oil to 10/30 and Im getting good readings so all good now.

  13. #13




    Array
    Status
    Offline
    Join Date
    03-20-2011
    Posts
    4,526
    Location

    Pittsburgh, PA
    Vehicle

    1980 Dodge D-50
    Engine

    G54B
    there are new sending unit available on ebay right now if you want the factory one to work: https://www.ebay.com/itm/Engine-Oil-...53.m1438.l2649
    Pennyman1
    The best Dodge that Dodge never made
    Living the D-50 lifestyle since 1980

  14. #14

    Array
    Status
    Offline
    Join Date
    01-24-2017
    Posts
    516
    Location

    New Zealand
    Vehicle

    1981 Mitsubishi L200
    Engine

    Other
    I got a new one from rock auto too

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •