Page 2 of 2 FirstFirst 12
Results 26 to 29 of 29

Thread: Smog fail need help!!!

  1. #26

    Array
    Status
    Offline
    Join Date
    06-15-2014
    Posts
    2,414
    Location

    Adelaide, South Australia
    Vehicle

    1985 Mitsubishi L200
    Engine

    G63B
    Quote Originally Posted by irotagrup View Post
    I'm pretty sure they are what I am running in it now, found 2 more new sets of 4 of them in the back. got to fix other stuff before I get back to this. Tranny rebulild
    Don't freak out over the transmission, it might have done something as small as drop the selector fork (this sometimes happen when the shifter is either loose or the nylon bush has worn out). If you go feeling around the main selector you can get it to relocate onto the selector fork and re-engage 3rd and 4th.

  2. #27

    Array
    Status
    Offline
    Join Date
    11-10-2012
    Posts
    129
    Location

    Esparto CA
    Vehicle

    1982 Dodge Power Ram 50
    Engine

    G54B
    Don't think it's that easy, oil had lots of metal in it, pretty sure 4th got powdered, might be the case for 3rd. Had no nylon bushing in it when I took it off

  3. #28



    Array
    Status
    Offline
    Join Date
    03-20-2011
    Posts
    4,146
    Location

    Pittsburgh, PA
    Vehicle

    1980 Dodge D-50
    Engine

    G54B
    4th gear is actually straight through with no gears involved, so I would think a selector fork is the issue here.
    Pennyman1
    The best Dodge that Dodge never made
    Living the D-50 lifestyle since 1980

  4. #29

    Array
    Status
    Offline
    Join Date
    11-10-2012
    Posts
    129
    Location

    Esparto CA
    Vehicle

    1982 Dodge Power Ram 50
    Engine

    G54B
    The fresh oil draind out was pretty shiny, had a nice metallic sparkle to it.

Page 2 of 2 FirstFirst 12

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •