Page 1 of 2 12 LastLast
Results 1 to 25 of 27

Thread: Fuel Issues... Possibly?

  1. #1

    Array
    Status
    Offline
    Join Date
    04-09-2015
    Posts
    212
    Location

    College Station, TX
    Vehicle

    1984 Dodge Ram 50
    Engine

    4D55-T

    Fuel Issues... Possibly?

    So I was buzzing around town in Wallace and almost made it to my destination when it started to run like it was almost out of fuel. It still had half a tank left, but I couldn't recall the last time I fueled up so it could be wrong... stranger things have happened. I made it to my destination and then parked it, but didn't have time to look it over. It fired up like normal when I was leaving and I made it about 4 miles of my 5 mile journey and it started acting up again.
    My initial suspicion was a bad fuel filter. I had an extra so I changed it before I drove it the next time. Was about 6 miles into my 8 mile trip and it started acting all starved of fuel. If I stopped and feathered the throttle it would start to seem fine and then I take off and it would bog down again.
    This is what I've observed thus far... 1) It wasn't the fuel filter. 2) It only seems to start acting up once the truck has reached operating temperature. Runs normal until it warms up, and runs even worse (after warmed up) if I try to hit the throttle hard, or am pulling any kind of hill. 3) And lastly, I did notice that the fuel injector for the #4 cylinder doesn't seem to be sealing properly. The place where it screws into the head shows evidence of some leakage, but nothing severe. It's just not sealed tightly I'm guessing, or a bad washer somewhere.
    To me if acts like it has bad spark plugs. But I looked all over for them and ruled that wasn't the issue.

    Thoughts?

  2. #2

    Array
    Status
    Online
    Join Date
    01-24-2017
    Posts
    503
    Location

    New Zealand
    Vehicle

    1981 Mitsubishi L200
    Engine

    Other
    Have you had it running in hot weather before, sounds a bit like the fuel is boiling off, might try a carb spacer. Edit* I see it's injected, possibly the temp sensor for the ecu is no good

    Also you might check the flow of the fuel pump, I have had a mechanical pump fill up with crap from the tank and could idle and low speed ok but anything more than walking pace would lean out and die. Have also had an electric pump wear out and would be fine till I got on the open road and put my foot down

  3. #3

    Array
    Status
    Online
    Join Date
    01-18-2015
    Posts
    245
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T
    Well not knowing anything about your truck, and being in the Diesel section. I am going to go on limb and say, there are no spark plugs.
    On a diesel if it acts "starved" then you have a turbo leak or turbo is failing. Though its possible its the injector pump dieing.

    If i assume you are in wrong section with a 2.4 injected. Lack of power would be fuel pressure, fuel filter, distributor timing, or dirty MAS

  4. #4

    Array
    Status
    Offline
    Join Date
    06-12-2015
    Posts
    92
    Location

    Owensboro, KY
    Vehicle

    1991 Dodge Ram 50
    Engine

    4D55-T
    Check your fuel pressure to the injection pump, mine has been having the issue of dying on me after it running for very long stretches and I've narrowed it down to the lift pump not being able to keep up, it does the same thing of acting like its running out of fuel.

  5. #5

    Array
    Status
    Offline
    Join Date
    04-09-2015
    Posts
    212
    Location

    College Station, TX
    Vehicle

    1984 Dodge Ram 50
    Engine

    4D55-T
    Quote Originally Posted by skullzaflare View Post
    Well not knowing anything about your truck, and being in the Diesel section. I am going to go on limb and say, there are no spark plugs.
    On a diesel if it acts "starved" then you have a turbo leak or turbo is failing. Though its possible its the injector pump dieing.
    It is a diesel. The spark plug mentioning was a joke. I just used that as reference to its symptoms.
    I thought a bad turbo would just give you a gutless engine, not sputtering and dying once it reached operating temp. A bad injector I have never dealt with before, so I'm not sure what kind of symptoms it would give. Is there anyway to troubleshoot either of your theories?

  6. #6

    Array
    Status
    Offline
    Join Date
    04-09-2015
    Posts
    212
    Location

    College Station, TX
    Vehicle

    1984 Dodge Ram 50
    Engine

    4D55-T
    Side thought... I converted this truck from gas to diesel. To my understanding it's just hard lines from the tank to the fuel filter for both models. Is there anything between the tank and the filter that shouldn't be there in a diesel model?

  7. #7

    Array
    Status
    Online
    Join Date
    01-18-2015
    Posts
    245
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T
    Quote Originally Posted by Uncle Spence View Post
    It is a diesel. The spark plug mentioning was a joke. I just used that as reference to its symptoms.
    I thought a bad turbo would just give you a gutless engine, not sputtering and dying once it reached operating temp. A bad injector I have never dealt with before, so I'm not sure what kind of symptoms it would give. Is there anyway to troubleshoot either of your theories?
    My truck is also a gas converted to diesel. 2nd gen (unaware what yours is)
    Mine was a carb truck, so only thing i did was run the fuel line to a clicker pump, then to a filter, then to the injection pump

    bad injector would either cause steady smoke as it dumped fuel in the cylinder, or a dead cylinder as no fuel passes

    at this point id say its probably in the injection pump. Cold pump is putting enough pressure, but once hot it cant build enough pressure

  8. #8

    Array
    Status
    Offline
    Join Date
    03-13-2016
    Posts
    12
    Location

    Berkeley, CA
    Vehicle

    1984 Dodge Power Ram 50
    Engine

    4D55-T
    Is this your daily driver? Have you driven it in the wintertime recently? (does it get cold where you are?)

    How did your fuel filter look when you changed it?

    I would say, before you go digging into the pump (I've done 2 in the last year...long story) to rule out the injectors and quality of your fuel.

    The quick and dirty way would be to run a can of sea foam through your engine. I would pull the filter again and fill it 1/2 to 3/4 up with seafoam, then bleed it and run it normally. If it is a gunky injector, that stuff might help.

    Also fill your tank up with new diesel, if its been sitting a while, the new stuff might dilute the bad stuff enough to run nicely (not sure why this would be a thermal-related problem, but can't hurt...)

    If you have a diesel shop around (or a pop tester yourself) you could pull the injectors and see how they spray. Not sure why they would start spraying bad once the engine heats up, but its a few hours quicker than pulling the pump, and hundreds cheaper than a bench test.

    My only other thought is that you could have a TINY defect in the head gasket or ring or somewhere else that would lead to you losing compression only at temp. Maybe one day once its warmed up, and you do decide to pull the injectors to test them, have a compression tester handy and confirm that you have good squeeze on all cylinders while its hot.

    But I'd try the seafoam first, definitely the cheapest/easiest fix.

  9. #9

    Array
    Status
    Online
    Join Date
    01-18-2015
    Posts
    245
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T
    Edit - read it wrong lol

  10. #10

    Array
    Status
    Online
    Join Date
    01-18-2015
    Posts
    245
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T
    Also check the pop off valve on back of intake, could be failing and opening sooner as the spring gets hot
    though you would notice the whooshing of it being open

  11. #11

    Array
    Status
    Offline
    Join Date
    04-09-2015
    Posts
    212
    Location

    College Station, TX
    Vehicle

    1984 Dodge Ram 50
    Engine

    4D55-T
    Simple update on the issue.
    First of all, I was having a leaky valve cover and I mean leaking! I retorqued the head bolts and it fixed the problem. I never thought that the head would be that twisted to cause the valve cover to leak so badly.
    I ran some sea foam through the filter. I didn't take off the filter though. I just disconnected the hose from the fuel line and dipped it in the can of sea foam, let it run for a while, put it back on the fuel line, and then did it again until the can was empty. I will say that it helped the issue not be as severe, but it still happens.
    I drove around town for about 35 minutes before it started to act up again. I'm going to try blowing out the hard fuel lines and all my hoses with a compressor to make sure there's not any blockage before I start toying with the injection pump. I'll try that compression test too, just to make sure there's not any leaks anywhere. I'll do a cold crank and a warm crank to see how much of difference there is in compression (if any). If everything looks good there and my other things don't resolve it, then I'm going to have to start looking for options for my injection pump. Based on my local inquires, my options are pretty limited.

  12. #12

    Array
    Status
    Online
    Join Date
    01-18-2015
    Posts
    245
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T
    Carry a gallon of water with you. Next drive when it starts acting up, shut it off, slowly pour the water over the pump cooling it down (use whole thing) and then start driving again. That will give you an idea if its in the pump

  13. #13

    Array
    Status
    Offline
    Join Date
    04-09-2015
    Posts
    212
    Location

    College Station, TX
    Vehicle

    1984 Dodge Ram 50
    Engine

    4D55-T
    Sound advice. I will do just that next time I'm buzzing around. Thanks Skullzaflare.

  14. #14

    Array
    Status
    Online
    Join Date
    01-24-2017
    Posts
    503
    Location

    New Zealand
    Vehicle

    1981 Mitsubishi L200
    Engine

    Other
    Recently had a guy with a similar problem. Could drive a little but had issues on the open road and on hills.
    In his case the fuel system needed bleeding due to an air bubble along with a weak battery

  15. #15

    Array
    Status
    Offline
    Join Date
    03-13-2016
    Posts
    12
    Location

    Berkeley, CA
    Vehicle

    1984 Dodge Power Ram 50
    Engine

    4D55-T
    If it ran well for the first half hour, then started to act up again, I'd suspect your fuel is bad. maybe the seafoam was helping it do a little of the running until it all got flushed out? If it helped, Buy some more and run it through again! maybe it is just gunk stuck somewhere.

    If you can, take the plug out of the bottom of the tank and empty it out. Refill with fresh diesel and see if that helps any. Maybe try bleeding your injection pump by cracking the nut on the return line while trying to prime the filter with the little piston pump.

    It also could be a timing thing, maybe check your plunger lift on the back of your fuel pump (you can be jenky and use a set of calipers that you hold real still if you don't have the fancy adapter and dial indicator the book recommends). The fuel pump also has a timing advance plunger in it that is run by the internal lift pump (as a function of RPM), which could be getting sticky. OR your internal lift pump could be going bad and not giving the advance plunger the pressure it needs to move and change the timing. The advance plunger is the lowest point in the fuel pump, so any goop or crap will settle out to there, not sure how that would be thermally related though...you'd have power issues all the time.

    I just looked all over for a new pump, theyre only available used, and will require a diesel pump shop to go through it for anywhere between $200-$900, depending on how much help it needs. I just got one from a guy in Greece, so I'll have one you could rebuild if you wanted, but its a crap shoot if you can get parts to replace the bad ones during the rebuild.

    Anyways, these are all just guesses, I'm scratching my head a bit here...

  16. #16

    Array
    Status
    Offline
    Join Date
    09-03-2017
    Posts
    1
    Location

    SE, PA
    Vehicle

    1985 Dodge Power Ram 50
    Engine

    4D55
    My guess is sediment in the fuel tank. I just replaced my tank due to a leak, and while mine runs fine, found a lot of gunk and such in the old tank.

  17. #17

    Array
    Status
    Offline
    Join Date
    04-09-2015
    Posts
    212
    Location

    College Station, TX
    Vehicle

    1984 Dodge Ram 50
    Engine

    4D55-T
    Well, I believe I found the issue. As mentioned previously it was running like it was starved of fuel, which was why I originally suspected the fuel filter being clogged or bad. That however was not the problem.
    This past weekend I took some compressed air and blew it through both the main fuel line and the return line. As a side note, make sure if you do this to open the fuel cap. I heard the tank expanding the first time I sent air to it and so I stopped and diesel fuel came spewing back out of the fuel line I just emptied. I also blew out all the fuel hoses leading to and from the filter to the injection pump. Then I drove the truck. I drove it for about an hour all around town, on the highway, up hills (if you can call them that, since I live in Texas) and even stopped in a parking lot to do some burnouts. Before this any hill or punching of the accelerator caused it to start bogging down and act fuel starved. The problem never came back in the hour of driving.
    So I treated a symptom at this point and still have to fix the actual problem. There's something in the tank that caused the blockage. Part of me thinks it the extra filter that's in the gas tanks that the diesel models did not have. Once I've burned through most of the fuel that's in it now, I will drain the tank and see what kind of gunk comes out of it. I did drain all of gasoline before I put diesel into it (so only a year ago) and it appeared to look just fine. To my knowledge this truck has never sat dormant besides the year or so that I had it before the rebuild and engine swap. So the tank interior should be just fine.
    Thank you all for your input and brainstorming. It's nice to beat ideas off people.

  18. #18

    Array
    Status
    Offline
    Join Date
    06-15-2014
    Posts
    3,208
    Location

    Adelaide, South Australia
    Vehicle

    1985 Mitsubishi L200
    Engine

    G63B
    Quote Originally Posted by Mirella View Post
    The quick and dirty way would be to run a can of sea foam through your engine. I would pull the filter again and fill it 1/2 to 3/4 up with seafoam, then bleed it and run it normally. If it is a gunky injector, that stuff might help.Also fill your tank up with new diesel, if its been sitting a while, the new stuff might dilute the bad stuff enough to run nicely (not sure why this would be a thermal-related problem, but can't hurt...)
    Ban their ASSES now - nice little advert slipped in there, doncha think?
    Last edited by camoit; 06-03-2018 at 06:04 AM.
    support the forum that supports you - join and donate to MightyRam50.Net Get perks and donations $15 USD and over receive official MightyRam50.Net window decals

  19. #19

    Array
    Status
    Offline
    Join Date
    04-09-2015
    Posts
    212
    Location

    College Station, TX
    Vehicle

    1984 Dodge Ram 50
    Engine

    4D55-T
    What I determined it to be was actually quite simple and should have been considered earlier by myself. I continued the air blow out method every time it would act up (about every 15-20 miles depending on aggressiveness of driving). Just carried a small bottle of compressed CO2 everywhere I went behind the seat. Carbonated diesel power!
    One morning on my way to work I was driving past a parts store, with maybe a gallon of fuel left in the tank, I stopped and bought 12 inches of 1/2inch fuel rated hose. I removed the hose that went from tank to the hard fuel line. That hose had the old gasoline fuel filter along it. I then installed my new hose. Diesel running all down my arm! Went home, changed my shirt... haven't had an issue since. That was probably in April.
    My first intuition when the problem started was that I had a bad fuel filter. I just changed the wrong one. According to the manual, the diesel model has just a hose running from the tank to the hard line. Now it's that much closer to being a factory diesel truck.

  20. #20

    Array
    Status
    Offline
    Join Date
    04-09-2015
    Posts
    212
    Location

    College Station, TX
    Vehicle

    1984 Dodge Ram 50
    Engine

    4D55-T
    Quote Originally Posted by geezer101 View Post
    Ban their ASSES now - nice little advert slipped in there, doncha think?
    Ya, what's with the weird link?

  21. #21

    Array
    Status
    Offline
    Join Date
    12-21-2013
    Posts
    1,140
    Location

    Maurertown, Virginia
    Vehicle

    1990 Dodge D-50
    Engine

    4G64
    [Post edited]
    Last edited by royster; 06-02-2018 at 01:09 PM.
    The greatest gift you have to give to the world is that of your own self~transformation.

  22. #22



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,629
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    Quote Originally Posted by geezer101 View Post
    Ban their ASSES now - nice little advert slipped in there, doncha think?

    Casino add stuck in there. Sly I didn't see it in moderation when it was there because the link was hidden.
    There gone and added to the spam data base.

    Thanks for the flag.

    The IP did come back to the usa.
    Members come and members go, But the board keeps track of them.
    Check out the Fear Monger by
    clicking HERE.

    The MightyRam50 site is sponsored in part by On Site Concrete Inc.

  23. #23

    Array
    Status
    Offline
    Join Date
    06-15-2014
    Posts
    3,208
    Location

    Adelaide, South Australia
    Vehicle

    1985 Mitsubishi L200
    Engine

    G63B
    Quote Originally Posted by camoit View Post
    Casino add stuck in there. Sly I didn't see it in moderation when it was there because the link was hidden.
    There gone and added to the spam data base.

    Thanks for the flag.

    The IP did come back to the usa.
    I was going to roll out my standard welcome until I noticed something smelled funky with their post. First was 'why does this post look familiar?', which drew me to the feeling it was cut and pasted, then the embedded text stood out like dogs. Oh well, another notch on the gun barrel and back to the thread peeps...
    support the forum that supports you - join and donate to MightyRam50.Net Get perks and donations $15 USD and over receive official MightyRam50.Net window decals

  24. #24

    Array
    Status
    Offline
    Join Date
    06-15-2014
    Posts
    3,208
    Location

    Adelaide, South Australia
    Vehicle

    1985 Mitsubishi L200
    Engine

    G63B
    Actually, all this crap needs to be deleted from this thread. My post alerting the site that there was an issue still has the offending post in it
    support the forum that supports you - join and donate to MightyRam50.Net Get perks and donations $15 USD and over receive official MightyRam50.Net window decals

  25. #25

    Array
    Status
    Offline
    Join Date
    12-21-2013
    Posts
    1,140
    Location

    Maurertown, Virginia
    Vehicle

    1990 Dodge D-50
    Engine

    4G64
    My post alerting the site that there was an issue still has the offending post in it
    Edit your post, and delete the quote
    The greatest gift you have to give to the world is that of your own self~transformation.

Page 1 of 2 12 LastLast

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •