Results 1 to 3 of 3

Thread: Spitting and sputtering

  1. #1

    Array
    Status
    Offline
    Join Date
    03-15-2016
    Posts
    17
    Location

    Spanaway, WA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64

    Spitting and sputtering

    So the truck is spitting and sputtering when I press the gas harder than normal and at higher speeds 50-65 doesn't accelerate much more than that also after running it kinda hard when coming to a stop it starts to bog down like its about to die but doesn't die ....if the MAF is unplugged it runs completely fine except at idle I have no idea what is wrong found a worn gasket between the intake manifold and throttle body replaced it and also replaced the MAF and the fuel filter also used a fuel injector cleaner checked for any vacuum leaks couldn't find any idk what to do running out of ideas
    Last edited by DroppedMitsu; 03-25-2016 at 10:57 AM.

  2. #2



    Array
    Status
    Offline
    Join Date
    03-26-2011
    Posts
    1,512
    Location

    Vacaville, CA
    Vehicle

    1989 Mitsubishi Mighty Max
    Engine

    4G63-T
    Please only post a thread one time, not in different sections, everyone will still see the post. If it is posted in the wrong section initially we can fix that, no need to post another thread just let us know.

    Do you have a check engine light on/any codes being thrown by the ECU? We have had people with badly clogged injectors with the same symptoms, they had to remove them and actually send them out to an injector service/cleaning place and have them ultrasonic cleaned. Not saying its your problem just a potential solution I've seen.
    Josh
    09 BMW 335i E92 Twin turbo
    89 Macrocab 4g63 Turbo swapped & Bagged: Build Thread

  3. #3

    Array
    Status
    Offline
    Join Date
    02-29-2016
    Posts
    49
    Location

    Oklahoma
    Vehicle

    1992 Mitsubishi Mighty Max
    Engine

    4G64
    could also be a rusty tank contaminating the fuel..
    it's probably worth dropping and taking a peek inside if you're running out of ideas... i had the same symptoms on a 91 3000GT, turned out my tank was full of rusty gunk, i ended up having to line it

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •