Results 1 to 5 of 5

Thread: problem after problem/:

  1. #1

    Array
    Status
    Offline
    Join Date
    04-05-2011
    Posts
    49
    Location

    Houma, LA
    Vehicle

    1995 Mitsubishi Mighty Max
    Engine

    4G64

    problem after problem/:

    well,got my truck back going and now its running horrible...
    its running like it has water in the gas,but it doesnt,i put gas in at three different places so far and still the same. ive changed the fuels pump,filter,plugs,MAF and its still doing it. it sputters a lot,but as soon as the temp needle moves,it clears up,and as soon as its warmed up,it runs perfect...HELPPP PLEASE!!!!

  2. #2



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,614
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    Sounds like it might a bad temp sensor. But I might be wrong
    Members come and members go, But the board keeps track of them.
    Check out the Fear Monger by
    clicking HERE.

    The MightyRam50 site is sponsored in part by On Site Concrete Inc.

  3. #3



    Array
    Status
    Offline
    Join Date
    03-26-2011
    Posts
    1,512
    Location

    Vacaville, CA
    Vehicle

    1989 Mitsubishi Mighty Max
    Engine

    4G63-T
    Yup, sounds like bad engine coolant temp sensor to me. Not exactly sure where it is located on the 2.4 though.
    Josh
    09 BMW 335i E92 Twin turbo
    89 Macrocab 4g63 Turbo swapped & Bagged: Build Thread

  4. #4

    Array
    Status
    Offline
    Join Date
    03-26-2011
    Posts
    24
    Location

    Buhl, ID
    Vehicle

    1989 Dodge Power Ram 50
    Engine

    G64B
    When my sensor went bad, it would go from high idle to almost die and then up again until it warmed up. Pull the sensor and measure the resistance. At 32 degrees it should be around 5.8 ohms. 68 - 2.4 104 - 1.1 176 - .3 So if you just pull the wire off and measure it at 70 degrees and it is not around 2.4 ohms then it is bad.

  5. #5

    Array
    Status
    Offline
    Join Date
    04-05-2011
    Posts
    49
    Location

    Houma, LA
    Vehicle

    1995 Mitsubishi Mighty Max
    Engine

    4G64
    yeah itll rev to like 1500 then drop to lik 300 then back up,then you rev it one good time and itll idle at abou 900 then when it warms up itll idle at its normal 1100,but ill swap mine with my buddys and see what it does

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •