Results 1 to 9 of 9

Thread: No Start

  1. #1

    Array
    Status
    Offline
    Join Date
    09-08-2015
    Posts
    3
    Location

    Sin City, NV
    Vehicle

    1989 Mitsubishi Mighty Max
    Engine

    4G64

    No Start

    Hey everyone-
    I race a 90 Might Max on a dirt track in Southern Nevada. Last Saturday night I was racing and in the middle of the race lost power. Truck will not start. Have no spark at the plugs. Rotor does turn. Truck has a 4G64 SOHC motor. Any help would be great!

    Thanks!

  2. #2

    Array
    Status
    Offline
    Join Date
    04-09-2014
    Posts
    595
    Location

    sheffield, vt
    Vehicle

    1978 Dodge D-50
    Engine

    G63B
    She's mighty mighty just lettin' it all hang out

  3. #3


    Array
    Status
    Offline
    Join Date
    04-04-2011
    Posts
    684
    Location

    Columbus, OH
    Vehicle

    1992 Mitsubishi Mighty Max
    Engine

    Other
    Myriad of reasons, check the ECU #1, MPI Relay,, everything else working lights? horn?

  4. #4

    Array
    Status
    Offline
    Join Date
    09-08-2015
    Posts
    3
    Location

    Sin City, NV
    Vehicle

    1989 Mitsubishi Mighty Max
    Engine

    4G64
    Thanks guys! Yes the lights, and tach work just fine. The motor cranks over, just won't fire. I have no spark at the plug, rotor turns fine. Battery is 100 % charged as well as we have tried with it on a charger. Sorry but what is a MPI Relay and where would it be located?

  5. #5

    Array
    Status
    Offline
    Join Date
    12-13-2014
    Posts
    122
    Location

    redding ca
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    if your truck is fuel injection than it will have an mpi relay. check the connectors on the passenger side firewall for corrosion. clean them and see what happens.

  6. #6


    Array
    Status
    Offline
    Join Date
    04-04-2011
    Posts
    684
    Location

    Columbus, OH
    Vehicle

    1992 Mitsubishi Mighty Max
    Engine

    Other
    also there is a cable from the base of the distributor to the firewall, that is the cam/crank angle sensor. if that is shorted/broken, then the ECU wont fire the plugs either, doesn't know where the crank is...a previous poster had this problem.

    If you need electrical diagrams... look here...http://www.mmeierle.com/Wiring%20Diagrams.htm

    there is also the 216 manuals thread on the board which will cover your truck... The mpi relay is behind the passenger kick panel, when you turn the key you should hear it "click"

  7. #7

    Array
    Status
    Offline
    Join Date
    09-08-2015
    Posts
    3
    Location

    Sin City, NV
    Vehicle

    1989 Mitsubishi Mighty Max
    Engine

    4G64
    Well we checked a few things and still no luck. We have power coming in to the coil, power coming out of the coil but still no spark. We replaced the coil and still nothing. I will try some of the things you guys have posted and see what happens.

    LSR Mike. This is a race truck, there is no key.

  8. #8


    Array
    Status
    Offline
    Join Date
    04-04-2011
    Posts
    684
    Location

    Columbus, OH
    Vehicle

    1992 Mitsubishi Mighty Max
    Engine

    Other
    Then when you apply power...
    I get the race truck part...


  9. #9

    Array
    Status
    Offline
    Join Date
    05-06-2015
    Posts
    61
    Location

    El Paso, Tx
    Vehicle

    1988 Mitsubishi Mighty Max
    Engine

    G63B
    No spark usually means the internal power transistor inside the distributor went bad. Either replace the distributor or convert yours to an external power transistor and coil.

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •