Results 1 to 5 of 5

Thread: Getting ready for the BIG START Gen 2 Mighty Max - Help of setting up Ignition Timing

  1. #1

    Array
    Status
    Offline
    Join Date
    08-04-2015
    Posts
    13
    Location

    usa
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4D55

    Getting ready for the BIG START Gen 2 Mighty Max - Help of setting up Ignition Timing

    Hi all,
    Ok, My Project is reaching fruition. Brand New engine (2.4 ltr), is all installed and I am ready to start her up. I have looked around the Forum but cannot find how to set up the timing correctly. Someone mentioned that I must disconnect the engine management somehow.
    Would someone please walk me through what I need to do to manually set up the timing with a timing light, what needs to be disconnected etc.
    Or maybe you can direct me to the Manual you have here in the forum or perhaps an appropriate thread.
    Thanks in anticipation
    Warthog

    (2.4 liter engine)

  2. #2

    Array
    Status
    Offline
    Join Date
    12-21-2013
    Posts
    1,033
    Location

    Maurertown, Virginia
    Vehicle

    1990 Dodge D-50
    Engine

    4G64
    The greatest gift you have to give to the world is that of your own self~transformation.

  3. #3

    Array
    Status
    Offline
    Join Date
    08-04-2015
    Posts
    13
    Location

    usa
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4D55
    Thanks Royster

  4. #4

    Array
    Status
    Offline
    Join Date
    08-04-2015
    Posts
    13
    Location

    usa
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4D55
    Ok the big start didn't happen.
    I can hear the Solenoid click but the starter does not kick in.
    So here is my question, is there anything that inhibits the starter from working? IE does the brake or clutch have to be depressed? Does the manual gearbox have to be in Neutral?
    If there are "safety" switches that inhibit starting.... where are they located?
    Many thanks in advance.

  5. #5

    Array
    Status
    Offline
    Join Date
    08-04-2015
    Posts
    13
    Location

    usa
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4D55
    One other point, when I push down the clutch pedal there is no resistance even though the lever on the side of the gearbox is moving. I have a bad feeling that I have connected the mechanism wrongly. If there is a switch in there maybe that is part of the problem?

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •