Results 1 to 16 of 16

Thread: 1988 Diesel Starion

  1. #1

    Array
    Status
    Offline
    Join Date
    01-18-2015
    Posts
    215
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T

    1988 Diesel Starion

    Figure ill move this here, so i can post updates

    So here it is, 88 conquest/starion, was making around 400hp with a stock bottom end 4g54 on MPI and billet hx40

    After breaking the drive shaft at the track, i decided to go a different route. I sold everything, planned to put a twin turbo lq4 (chevy 6.0) in the car.
    During parts gathering i ran across a good deal on a 4d56, so i sold everything again! lol, now i have the 2nd in the world known 4d56 Starion
    this is my old setup on a wh1c before i got my hx40




    During the install


    here is the first start
    https://youtu.be/KwI8locWNII

    initial test drive open elbow off turbo
    https://youtu.be/wgBWxf9fSgI

    First oil leak


    didnt take long after i starting learning on how to adjust the injection pump. turned fuel and boost up, running 25-30psi on the stock turbo
    didnt last long though lol


    Ordered a custom Kinugawa td04-15t billet


    Received a Delica l200 gauge cluster, i began cutting it out and figuring out how it worked to make a tach work in my car off the factory rev counter
    https://youtu.be/AR1f-e5hILM

    Tach in the dash




    testing the 15t on 25psi




    Long jump forward of small pitally things
    made piping to put a stock intercooler on the car, added a egt gauge, added a nice big Fuso 6.6l diesel fuel filter, upgraded to a 3 row s13 sr20 radiator, high power 14" 2 speed fan mounted on front as backup, 14" flex fan mounted on pump for primary






    yesterday had a change to pull valve cover off and clean it up, readjust the valves too
    looks better in person, seems the red was oversaturated in the pic

  2. #2

    Array
    Status
    Offline
    Join Date
    01-18-2015
    Posts
    215
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T
    well started yesterday, pulled a gas motor out of my silver shell and began getting it ready. Swapping from the blue bucket to the silver roller started today. though not pictured the motor is now in the silver car, but have not changed fuel tanks/pumps or wiring yet.
    on another note, the silver is auto, so no more noisy trans, and i feel like im getting old, im tired of shifting lol

  3. #3

    Array
    Status
    Offline
    Join Date
    01-18-2015
    Posts
    215
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T

  4. #4

    Array
    Status
    Offline
    Join Date
    12-13-2014
    Posts
    122
    Location

    redding ca
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    that is AWESOME!!! ive been thinking about putting the 4d56 in one of my trucks or building a turbo 4g64. have the dohc for the 4g64 but witch one do you think is more fun? also are you using the stock tranny?

  5. #5

    Array
    Status
    Offline
    Join Date
    01-18-2015
    Posts
    215
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T
    Stock manual was making noise when I put motor in, and I was towing with it.
    Putting in car with stock auto now

    Depends what you are doing, if you run the stock turbo and stock boost, a stock 4g64 would be more fun. Even with my upgraded turbo to the billet 15t and 30psi, it's still a sled compared to a stock turbo g54

  6. #6

    Array
    Status
    Offline
    Join Date
    03-29-2011
    Posts
    68
    Location

    Chattanooga, TN
    Vehicle

    1987 Mitsubishi Montero
    Engine

    4D55-T
    FYI, When Tye put the diesel in the auto Raider, he had to flip the gear on the starter.

  7. #7

    Array
    Status
    Offline
    Join Date
    01-18-2015
    Posts
    215
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T
    I have been using the gas starter no issues, I do have a diesel starter, I tried to flip the gear but the retainer ring wouldn't go back in flipped

  8. #8

    Array
    Status
    Offline
    Join Date
    03-29-2011
    Posts
    68
    Location

    Chattanooga, TN
    Vehicle

    1987 Mitsubishi Montero
    Engine

    4D55-T
    PM wrngwae on SQC for more insight in running an auto if need be. Looking forward to seeing how this pans out.

  9. #9

    Array
    Status
    Offline
    Join Date
    01-18-2015
    Posts
    215
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T
    Got it running tonight, with a Few wires tied together lol.
    Seems the shifter is out of adjustment, have to put it in the lower select to get upper, aka reverse is neutral, drive is 2nd
    However once I put it in drive (2nd) I can push it back to drive and it stays in.
    Park is Park always though so I don't know lol.
    With wheels in the air I tried to get it to shift, but it said no lol

  10. #10

    Array
    Status
    Offline
    Join Date
    01-18-2015
    Posts
    215
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T
    Update.
    Cars trans wasn't good lol. 1st was good, 2nd slipped bad, could only use 3rd if i activated passing gear (3rd worked good) otherwise went directly to OD, nothing would cancel it, OD slipped too.
    Drove for a week, swapped trans for a unknown I got out of a field lol
    This trans works great, 2nd is a little weak sometimes, 3rd is great, OD is Ok.
    So now I'm 2900rpm at 85mph instead of 70mph

    Downside, may be from this stupid cold front, I have been warming the car up. I lost 5mpg

  11. #11

    Array
    Status
    Offline
    Join Date
    01-18-2015
    Posts
    215
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T
    So now this one is failing lol, it slipped a little to begin with, so i knew i was on borrowed time. In the process of rebuilding the original. Nothing left of some of the clutches

  12. #12

    Array
    Status
    Offline
    Join Date
    08-31-2015
    Posts
    68
    Location

    Nunn, Colorado
    Vehicle

    1981 Dodge Ram 50
    Engine

    G54B
    Are mounts the same for both motors?

  13. #13

    Array
    Status
    Offline
    Join Date
    01-18-2015
    Posts
    215
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T
    on the starion, i made the L300 motor mounts work (they were a little taller) until i got new g54 mounts. but it all bolts in the same place

  14. #14

    Array
    Status
    Offline
    Join Date
    01-18-2015
    Posts
    215
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T
    Fast forward to the present/few weeks ago

    I finally finished rebuilding the trans, put it in, no reverse/N/P...
    Swapped valve bodies, same thing...

    Yesterday i made a 12hr road trip, came back with some body parts and transmission.

    Spent all day today, it is on the road again!
    Trans feels a little better than the one i took out. but this will allow me to disassemble the one i removed and the new, to see what i did wrong

  15. #15

    Array
    Status
    Offline
    Join Date
    06-15-2014
    Posts
    2,242
    Location

    Adelaide, South Australia
    Vehicle

    1985 Mitsubishi L200
    Engine

    G63B
    Time for an autopsy! Glad you got it back on the road. A lotta driving just to get parts for it though. Guess it's the nature of the beast...

  16. #16

    Array
    Status
    Offline
    Join Date
    01-18-2015
    Posts
    215
    Location

    Inwood WV
    Vehicle

    1991 Mitsubishi L200
    Engine

    4D56-T
    Quote Originally Posted by geezer101 View Post
    Time for an autopsy! Glad you got it back on the road. A lotta driving just to get parts for it though. Guess it's the nature of the beast...
    Yep not happy about it either lol
    Going to get some 2x4's and build a frame to hold 2 trans so i dont have to keep rolling them around while i pull the rebuilt and pulled one apart to see what i screwed up lol

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •