Results 1 to 4 of 4

Thread: No low beam on my 91.

  1. #1

    Array
    Status
    Offline
    Join Date
    04-10-2011
    Posts
    256
    Location

    WA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    6G72

    No low beam on my 91.

    The low beams are out on my son's 91, high beams work fine. Swapped out the control switch with a known good one but got same result. Wiring diagram shows a combination meter between the switch and the headlights but I can't locate it. Any help would be appreciated.
    1990 MM 4x4 3.0
    1991 MM 4x4 3.0 Diamonte
    1994 MM 2wd (work in progress)

  2. #2

    Array
    Status
    Offline
    Join Date
    04-10-2011
    Posts
    256
    Location

    WA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    6G72
    Never mind, turned out to be faulty fuse connection. I always tell myself to stick with the simple stuff first, should have listened to that little voice!
    1990 MM 4x4 3.0
    1991 MM 4x4 3.0 Diamonte
    1994 MM 2wd (work in progress)

  3. #3

    Array
    Status
    Offline
    Join Date
    03-27-2011
    Posts
    61
    Location

    Durham, NC
    Vehicle

    1994 Mitsubishi Mighty Max
    Engine

    4G64
    Ive had the same trouble with my fuse connection, and a few others I know have too.

  4. #4



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,614
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    hahaha you fixed it in 50 minutes..
    Members come and members go, But the board keeps track of them.
    Check out the Fear Monger by
    clicking HERE.

    The MightyRam50 site is sponsored in part by On Site Concrete Inc.

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •