Results 1 to 6 of 6

Thread: motor won't rev up in gear

  1. #1

    Array
    Status
    Offline
    Join Date
    07-24-2014
    Posts
    9
    Location

    yakima, wa
    Vehicle

    1987 Mitsubishi Mighty Max
    Engine

    G54B

    motor won't rev up in gear

    hey hows everybody doing

    I have a problem with my mighty max. it can rev up fine in neutral, it will keep revving until it blows. in gear though it will only hit 5,000 in first, 4,500 in second, and 4,000 in 3rd. it hit these rpms In gear and the truck bounces back and forth with the rpms bouncing as well. I have pushed the clutch in when this has happened and the revs skyrocket but immediately hit the wall when clutch is released.

    what is going on here? I have asked several people and no one knows.

    only one time I have hit 6k in first and second. and she was pulling!

    I can achieve 20+ second 0-60 runs right now. and that's with the weber 38 and brand new top end! I figure it should be about 10 or 11.

    any help would be appreciated

    thanks

  2. #2



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,614
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    The coil is old and can't make spark fast enough. Or fuel filter.
    Members come and members go, But the board keeps track of them.
    Check out the Fear Monger by
    clicking HERE.

    The MightyRam50 site is sponsored in part by On Site Concrete Inc.

  3. #3

    Array
    Status
    Offline
    Join Date
    07-24-2014
    Posts
    9
    Location

    yakima, wa
    Vehicle

    1987 Mitsubishi Mighty Max
    Engine

    G54B
    hey thank you. i'll see if that fixes the problem

  4. #4



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,614
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    The fuel filter is in a dark spot up in front of the tank on the inside of the frame rail left side. It's a PIA to swap but it should fix all of it.
    Members come and members go, But the board keeps track of them.
    Check out the Fear Monger by
    clicking HERE.

    The MightyRam50 site is sponsored in part by On Site Concrete Inc.

  5. #5

    Array
    Status
    Offline
    Join Date
    07-24-2014
    Posts
    9
    Location

    yakima, wa
    Vehicle

    1987 Mitsubishi Mighty Max
    Engine

    G54B
    alright i'll change that sucker


    why would it be revving fine in neutral though?

    I don't know if this has to do with the fuel filter but when given gas below NOT the motor will actually rev about a second after I step on the gas, and even drops a couple hundred rpm as I step on it. motor will also go from 1100 rpm idle to 500-600 loping. can not run factory recommended 800 rpm as it will want to idle at 300 when cold.

    any ideas

  6. #6



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,614
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    In neutral it it takes very little fuel because the power demand is low. But under a load it will use more fuel and needs to flow faster. Simple supply and demand. You demand more power it needs to flow more fuel.
    Members come and members go, But the board keeps track of them.
    Check out the Fear Monger by
    clicking HERE.

    The MightyRam50 site is sponsored in part by On Site Concrete Inc.

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •