Results 1 to 2 of 2

Thread: my motor took a poo

  1. #1

    Array
    Status
    Offline
    Join Date
    01-07-2012
    Posts
    4
    Location

    augusta ga
    Vehicle

    1989 Dodge Ram 50
    Engine

    Please Select Your Engine Type

    my motor took a poo

    I have a 89 2.0. A few months back I was at about 4000 rpm and my engine started to make a bad noise. But it only did it when I touch the throttle and wen starting It up. At idol it runs fine and no noise at all. So I park It for a few months frustrated. Well last weekend I pulled the motor and find some debris in the oil pan and oil in my intake. I also find that what I think is my balance shaft has a small amount of play and another shaft that looks just like it (closer to the head) spins freely. So I'm kind of lost. I've never messed with the internals of an engine. So is that normal to free spin like that? I've even told its most likely I have dome bad piston rings. Any opinions/ advice of help would be awesome. Should I trash the motor? It only has 89000 miles.

  2. #2

    Array
    Status
    Offline
    Join Date
    12-21-2013
    Posts
    1,033
    Location

    Maurertown, Virginia
    Vehicle

    1990 Dodge D-50
    Engine

    4G64
    Advice: you don't need to be at 4,000 RPM. Just a guess, but I never exceed 3,000, so I'm just imagining the whine it must make.

    The shaft nearest the head, as you are facing the engine, is a silent shaft, and it is run by its own timing belt. Did the timing belt on it break? Might explain some of the problem.

    Oil in the intake sounds to me like jet valve problems.

    If the engine isn't running at all, I'd suggest you dismantle it enough to remove the cylinder head. That will let you see what's going on in there.

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •