Results 1 to 19 of 19

Thread: idles fine, no power

  1. #1

    Array
    Status
    Offline
    Join Date
    09-19-2013
    Posts
    23
    Location

    Bakersfield,CA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64

    idles fine, no power

    ok, so I washed the engine 2-3 weeks ago and the mm started fail. at first it would just feel like the motor was cutting out while I was going the highway sort of like the governor kicks in while I was cruising @ about 70 mph. then the engine would die when I was coming up to a stop. on Tuesday I was coming down the grade and engine jerked and shut off and wouldn't start back up. after pulling off the freeway I unplugged all the electrical connection and re plugged them including the ECU. it starts now and idles fine but bogs down and shut off as I accelerate. I thought possibly the timing belt jumped a tooth but after getting it towed home I checked the timing and its right where it should be. need help please.

  2. #2

    Array
    Status
    Offline
    Join Date
    04-10-2011
    Posts
    256
    Location

    WA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    6G72
    I'm guessing, if it is related to the engine wash, you loosened something electrical. I would start with the basics, plugs and wires. Are they relatively new? Clean air filter? Look over your wiring harness for any spots it may be rubbing and possibly shorting out. Has your ecu ever been rebuilt? A plugged cat can cause bogging as well. Good luck and let us know your progress, it's always educational.
    1990 MM 4x4 3.0
    1991 MM 4x4 3.0 Diamonte
    1994 MM 2wd (work in progress)

  3. #3



    Array
    Status
    Offline
    Join Date
    03-20-2011
    Posts
    4,115
    Location

    Pittsburgh, PA
    Vehicle

    1980 Dodge D-50
    Engine

    G54B
    check your cap and rotor on the dizzy - my Dad tried to drown his 88 Ram 50 twice and it would run like that after he submerged it - the second time was after I fixed it and he borrowed it from me
    Pennyman1
    The best Dodge that Dodge never made
    Living the D-50 lifestyle since 1980

  4. #4

    Array
    Status
    Offline
    Join Date
    09-19-2013
    Posts
    23
    Location

    Bakersfield,CA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    how can you tell when the cap is bad? I checked it yesterday the little brass looking pieces look dark brown.is that a good indication it needs to be replaced?

  5. #5

    Array
    Status
    Offline
    Join Date
    09-19-2013
    Posts
    23
    Location

    Bakersfield,CA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    thanx. ill replace it tomorrow after work. I hope its something as simple as replacing the dist.cap.
    Quote Originally Posted by pennyman1 View Post
    check your cap and rotor on the dizzy - my Dad tried to drown his 88 Ram 50 twice and it would run like that after he submerged it - the second time was after I fixed it and he borrowed it from me

  6. #6

    Array
    Status
    Offline
    Join Date
    09-19-2013
    Posts
    23
    Location

    Bakersfield,CA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    no luck .just ran to oreillys and bought the cap and rotor and replaced it. still bogging down as I accelerate.

  7. #7



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,614
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    Did you knock off a vacuum line from the distributer? Sounds like an advance problem. Or injectors not working.
    Members come and members go, But the board keeps track of them.
    Check out the Fear Monger by
    clicking HERE.

    The MightyRam50 site is sponsored in part by On Site Concrete Inc.

  8. #8

    Array
    Status
    Offline
    Join Date
    09-19-2013
    Posts
    23
    Location

    Bakersfield,CA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    It has an electronic advance and the -injectors were replaced just over a year ago along with the fuel pressure. Regulator. And I just replaced the fuel filter last week thinking it might of been the culprit

  9. #9



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,614
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    You got water into something that did not like it. It probably dried and left a trail of calcium and it's conducting electricity so the ECU is getting a bad reading. Have you tried pulling every plug and cleaning the front and back with carb cleaner? It's got to be something like that. Or the mas air flow sensor got crap on it.
    Members come and members go, But the board keeps track of them.
    Check out the Fear Monger by
    clicking HERE.

    The MightyRam50 site is sponsored in part by On Site Concrete Inc.

  10. #10

    Array
    Status
    Offline
    Join Date
    09-19-2013
    Posts
    23
    Location

    Bakersfield,CA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    I've disconnected all plugs and de connected them ..but no I didn't spray cleaner on them. Is it safe to use Carb cleaner on electrical connections.is there a special. Spray for that?

  11. #11



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,614
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    There is an electrical contact cleaner out there but like all cleaners it can melt the plug. I found brake clean is fairly non reactive with the plastic. Just be sure to do a test one first before going nuts on them all. Also do an ohm test on the TPS.
    Members come and members go, But the board keeps track of them.
    Check out the Fear Monger by
    clicking HERE.

    The MightyRam50 site is sponsored in part by On Site Concrete Inc.

  12. #12

    Array
    Status
    Offline
    Join Date
    09-19-2013
    Posts
    23
    Location

    Bakersfield,CA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    With keep getting. Codes 22&25

  13. #13

    Array
    Status
    Offline
    Join Date
    09-19-2013
    Posts
    23
    Location

    Bakersfield,CA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    So iguess I need a new distributor and MAF. SENSOR.

  14. #14

    Array
    Status
    Offline
    Join Date
    09-19-2013
    Posts
    23
    Location

    Bakersfield,CA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    I replaced the distributor today. No longer getting code 22 on the CEL. still not running right. And getting. Codes. 13&25 one the cel. That's intake air temperature sensor and barometric pressure sensor. FML.

  15. #15

    Array
    Status
    Offline
    Join Date
    09-19-2013
    Posts
    23
    Location

    Bakersfield,CA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    I checked the mass air flow sensor.seems to be working fine.

  16. #16

    Array
    Status
    Offline
    Join Date
    09-19-2013
    Posts
    23
    Location

    Bakersfield,CA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    I found a used MAF sensor at Atlanta dismantling in NoHo
    . Last week. I swapped it out this morning and replaced my spark plugs and cleaned out the egr .still my MM doesn't have much power I had it floored in third gear and it putted up to 45 MPH.

  17. #17

    Array
    Status
    Offline
    Join Date
    09-19-2013
    Posts
    23
    Location

    Bakersfield,CA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    My cat was plugged. Apparently it melted when my fan belt come loose. Should be picking it up from the shop today.

  18. #18


    Array
    Status
    Offline
    Join Date
    08-31-2011
    Posts
    788
    Location

    Calgary, Alberta, Canada
    Vehicle

    1981 Dodge D-50
    Engine

    Ford V8
    Take it to a vet or get a new cat

  19. #19

    Array
    Status
    Offline
    Join Date
    06-21-2011
    Posts
    111
    Location

    Monticello, IN
    Vehicle

    1988 Mitsubishi Mighty Max
    Engine

    G63B
    Sucks you live in cal. I took my cat off and knock everything out. Still didnt help me though.

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •