Results 1 to 24 of 24

Thread: 90 MM ... a few issues.

  1. #1

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15

    90 MM ... a few issues.

    I just bought a 90 MM. It has 104K miles on it and a few issues to resolve.

    I need to find exactly which engine I have because to register I just chose the first option until I check.
    2.4L FI
    I have some mechanical knowledge but it is limited and I am new to this truck and motor so please go easy on me! haha
    Anyways the problems I am having and what I have already fixed.

    Average about 23-24 mpg on 93 octane.
    First off ... I had the CEL for coolant temp sensor- replaced.
    replaced top and bottom coolant hoses.
    replaced thermostat
    replaced most of the vacuum lines that I can find.
    Replaced PCV.
    Air filter looks perfect.
    MAF looks new
    the other sensors around the intake look a little grimey though.
    Some of this is just preventative maintenance and old parts off new parts on swap.


    I need to soon install a tach because I don't like that I can't tell the RPMs.
    I have started to notice an oil leak near the top half of the timing belt cover ... it is leaking where the bottom half and top half meet. I have not found the courage to pull this off yet to see exactly what might be leaking the oil.
    The valve cover seems to have slowed down on the leaks ... it must have sat a little while with minimal driving. Older man owned and rarely driven in the past 2-3 years.
    The oil is best I can tell (jug behind the seat) castrol dino oil 10w-30. I am thinking of going to MaxLife because everyone told me not to put Mobil 1 full syn in it. (don't know why though)


    So my biggest issues ...
    the idle is not what I am used to. I burn 93 in it so that it is clean and I know the possible old gas in the tank will burn out smoother. I crank it and I get the valve rattle (imports!) and it lags then fast idles then back to slower idle then back ... it smooths out but it is a noticeable fast and slow idle pattern. I am thinking my IAC and TPS might need to be pulled and cleaned ... carb cleaner??? Can where throttle attaches to the intake (top say EFI) and clean it then replace ... I think it has a gasket there as well - or is it better left in place?
    Now I have noticed that when I am slowing down on the highway and I put it in neutral to idle while coming to a stop or a turning lane it will almost bottom out on the idle and the oil light will flicker. I am probably going to go ahead and replace the oil sensor b/c it is a 8.00 part and looks to be easy to replace.
    How hard is the dash to remove if I need to replace my Speedo cable? I had a morning of bouncing speeds and I will probably need to replace or grease sometime soon.
    Hopefully last issue for tonight ... when I start the truck either in the mornings or for the first time in hours it sometimes seems to "backfire" under the hood ... that's the sound it makes anyways. If I start it up and take off first gear will hop and bounce and a muffled "poof" noise can often be heard ... same way for 2nd and 3rd until it winds up or if it warms up first it is smooth as butter.


    This truck seems fairly simple and straight forward but I hate to get in over my head.

    I just parked my 97 Nissan Hardbody for some work when I found this ... I love smaller import trucks!

    Many of these issues are probably simple to many people ... please any help at all is greatly appreciated. This is my main ride right now and I need to get her into a bit better shape. I drive about 60 miles round trip and then to night college after work weekly. It feels pretty reliable but I really want to make it better all around ... THANK YOU!!! I appreciate any and all help.

    BTW I have searched for some of these issues but I have never found true answers for my issues!
    THANKS!
    AFF

  2. #2

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15
    I probably should have started this in tuning. sorry!

  3. #3

    Array
    Status
    Offline
    Join Date
    12-21-2012
    Posts
    181
    Location

    North West Florida
    Vehicle

    1994 Mitsubishi Mighty Max
    Engine

    4G64
    Welcome. When your idle goes up and down, does it stop or smooth out once the engine is warm?

  4. #4

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15
    Quote Originally Posted by sleeps View Post
    Welcome. When your idle goes up and down, does it stop or smooth out once the engine is warm?
    For the most part it smooths out. I noticed this morning that I turned the motor over and it ran ... a little rough so I was going to let it warm up while i pulled the garbage can to the road. I made it three feet from the truck and it died. When I fired it back up she ran pretty normal. I notice the hesitation in gears 1, 2, and a little in 3rd but by the time I hit 4th and 5th it is smooth running and heads on down the road.

    These may only be small problems but they are problems still. Thanks for all the info and help.

  5. #5

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15
    Tomorrow if possible I am going to put the truck in the air and replace the fuel filter, plugs and wires, and see what issues I can resolve under the truck lol

    Can anyone offer some insight on the metal water pipe that runs under the exhaust from the water pump to the backside of the engine? Mine appears to be leaking around the seal where it connects to the pump and the block ... how can I remedy this?

  6. #6


    Array
    Status
    Offline
    Join Date
    04-04-2011
    Posts
    686
    Location

    Columbus, OH
    Vehicle

    1992 Mitsubishi Mighty Max
    Engine

    Other
    For the water leak, it's just a O-ring seal, have you checked the base timing?

    here's a good pix of the water pipe that bolt and one on the back on the drivers side gets it off... bolts are a PITA to get at though.


  7. #7

    Array
    Status
    Offline
    Join Date
    12-21-2012
    Posts
    181
    Location

    North West Florida
    Vehicle

    1994 Mitsubishi Mighty Max
    Engine

    4G64
    Or the pipe could be rusted and has a small hole in it. Happened to me, I replacd the o-ring about 3 times before I realized it was a pine hold right next to it.

  8. #8

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15
    If it ends up being the pipe and not the o-rings how exactly does it come out? the backside is obscured ... is that where you are talking about the bolts? If I need to replace could I use copper tubing that would match the same diameter? I know a lot of people say hack off the ends and put on heater hose but if it is too rotten I figured I could use copper tubing ... easy to work with, easy to find the right size, but might corrode a little and not really rust.

  9. #9

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15
    Quote Originally Posted by LSR Mike View Post
    For the water leak, it's just a O-ring seal, have you checked the base timing?

    here's a good pix of the water pipe that bolt and one on the back on the drivers side gets it off... bolts are a PITA to get at though.


    Just got a look at the pipe while it was on the rack. I see a few small leaks from mine but none seem to actually come from the metal hose. It appears oil has covered it and maybe kept the outside nice and lubed from the elements lol.
    Mine is around the inserts so I might pull it back and seal it then push it back up for now. Noticed the passenger side valve cover is leaking along with the half moon seal on it as well ... figures with an import. Replaced my fuel filter and oil press sensor. Both of which would have been a cursing fit had i been lying down on my back and not standing under it! Thankfully I had a lift for that!

    I'll note any changes as the days go by. Thanks for all the help and info!!

  10. #10

    Array
    Status
    Offline
    Join Date
    12-21-2012
    Posts
    181
    Location

    North West Florida
    Vehicle

    1994 Mitsubishi Mighty Max
    Engine

    4G64
    They usually rust from the inside out, not outside in. Ans once you take the bolts out the pipe should pop out with a little pressure. The o-rings seal it up and the bolts hold it in place. Hope you get it all fixed.

  11. #11

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15
    Quote Originally Posted by sleeps View Post
    They usually rust from the inside out, not outside in. Ans once you take the bolts out the pipe should pop out with a little pressure. The o-rings seal it up and the bolts hold it in place. Hope you get it all fixed.
    Thanks
    I will keep working on it ...

    I'm going to see how if fires up in the morning now that it has a new fuel filter. feels a little smoother now especially while driving ... i guess it could have an impact on the idle too!

  12. #12

    Array
    Status
    Offline
    Join Date
    04-10-2011
    Posts
    256
    Location

    WA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    6G72
    Dirty injectors can cause that hesitation, not uncommon if the vehicle has been sitting for a while. How is the top end speed/acceleration? My '91 "bucked" when I exceeded about 45 until I had my injectors cleaned.
    1990 MM 4x4 3.0
    1991 MM 4x4 3.0 Diamonte
    1994 MM 2wd (work in progress)

  13. #13

    Array
    Status
    Offline
    Join Date
    08-24-2013
    Posts
    188
    Location

    Alexander City, AL
    Vehicle

    1995 Mitsubishi Mighty Max
    Engine

    4G64
    Use seafoam and or Chevron Techron FI CLeaner Use both bottles in a 1/2 tank of fuel (w/o alcohol if available). Run a t least 1/2 of the 1/2 tank before refilling the tank. Set timing..I'd bet that is part of the issue at least! Make sure its not a tooth off re timing belt/gear etc, if it won't time correctly///

  14. #14

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15
    It runs great on top end. I have been running some Lucas through it at each fill up. I never run a vehicle below a half tank so it is probably getting a double dose of injector cleaner. I might eventually pull the injectors and have them cleaned but it seems to work great at 60, 65, 70, 75, and 80.

    to thillskier ... I HOPE ITS NOTHING TO DO WITH THE TIMING !!! Lol a timing issue is the reason my 97 Nissan Hardbody is parked in the yard awaiting a diagnosis and repair ... i miss that truck. Anyways I hope it is nothing to do with timing but I guess I should have hooked up the timing light while I was at the shop yesterday. Dang hindsight!

    I appreciate all the info and help!

    Btw I just started to run clean 87 octane through it this tank of gas. I was running 93 to make sure the octane was high enough ... i really didn't want to drain the tank ... changed the filter yesterday ... oh what fun!


    Thanks!!!

  15. #15

    Array
    Status
    Offline
    Join Date
    08-24-2013
    Posts
    188
    Location

    Alexander City, AL
    Vehicle

    1995 Mitsubishi Mighty Max
    Engine

    4G64
    What did the filter look (and feel) like? Was it "full" of crud? When you turned it upside down did crud/water come out? I ALWAYS dump the filter into a cup/glass to "inspect" what I can get out of the filter...If its bad, replace it again after a month or so, and maybe cut the old one in 2 to inspect it... That will tell you a LOT of possibilities you can eliminate by knowuing the tank (and fuel system) condition before diagnosing at the engine...

  16. #16

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15
    The filter wasn't that bad really ... it wasn't that great either.

    I now have a weird problem I think might be related to dropping down to 87 octane. If I am cruising along and I drop it into neutral to stop at a red light ot something the oil light comes on in a blinking fashion. I check the oil almost every day to ensure the level is correct. I think the motor is idling way down after being held at a higher rpm level and does not recover like it should ...

    any ideas?

  17. #17

    Array
    Status
    Offline
    Join Date
    12-21-2012
    Posts
    181
    Location

    North West Florida
    Vehicle

    1994 Mitsubishi Mighty Max
    Engine

    4G64
    This all sounds like idle air controll issues. Replace or take it out and apart and clean the carbon and the plunger out, see if that helps.

  18. #18

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15
    Sleeps ... thanks for always replying!

    I hate to ask this but I need a little more info.

    I believe this might give the picture I found of an exploded view of the intake and everything.

    How difficult of a job is the disassembly and cleaning process of the IAC? Should I clean the valve or the sensor portion? Should I use carb cleaner or something else? I still have MAF sensor cleaner if that would work better.

    I have never dealt with this sensor on any vehicle so I want to make sure I don't mess anything up ... I think the sensor runs about 150.00 on the cheap side and some stores want even more.

    I had started to wonder if the fuel pressure regulator would give this kind of trouble also?

    It starts up fine in the morning (and any other time as a matter of fact ... whether it is cold start or warm start)- it will cruise fine from 5 to 85mph. It just seems to happen when I have been driving and I stop at a red light ... i pull it into neutral (manual trans) and whether I am on the brakes or not the oil light flickers pretty steadily.

    Is there also a way to check my oil pressure myself? Never test oil pressure before ... never needed to really - until now!

    Thank you again for all the help! I have really fallen in love with this truck ... but I know she has a few problems ... I would rather fix them now while small rather than later with the problem is huge!!!

    THANK YOU!!!

  19. #19

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15
    oh i forgot to include this ...

    maybe it will post ...


    http://s3.amazonaws.com/2cp-images/q...5457/large.jpg

  20. #20

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15
    it came out as a link ... the link should pop up as a picture of the exploded view of the intake and components.

  21. #21

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15
    Left work on my way to school yesterday and I stopped to fill up the tank ... I happened to notice some fluid running from the bottom. Yep, that metal coolant hose is leaking like crazy! Called a dealership in Nashville and 83.00 later the part is ordered and should ship her hopefully by friday. Oh yeah and another tow bill ... it's always something!

  22. #22

    Array
    Status
    Offline
    Join Date
    12-21-2012
    Posts
    181
    Location

    North West Florida
    Vehicle

    1994 Mitsubishi Mighty Max
    Engine

    4G64
    Sorry to hear that. A fuel leak can cause some problems as well. I would wait to do anything else till you get that replaced. Ill take some pics this weekend or later this week if I remember too of the IAC and what to do on it. Sorry for the late reply.

  23. #23

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15
    Quote Originally Posted by sleeps View Post
    Sorry to hear that. A fuel leak can cause some problems as well. I would wait to do anything else till you get that replaced. Ill take some pics this weekend or later this week if I remember too of the IAC and what to do on it. Sorry for the late reply.
    Thank you!

    This is a horrible week!
    Monday truck breaksdown.
    Tuesday someone steals 206.00 from my account.
    Today the spare car ... buick lesabre is burning or leaking about 1/2 pint to a whole pint of trans fluid within about 100 miles or a little more.

    What a great week thus far!

    I'll check back this for the pix ... thanks sleeps i do appreciate it!

    I'll keep checking back for more details ... thanks everyone. It's at the shop right now ... maybe i'll get a call?!?!?

  24. #24

    Array
    Status
    Offline
    Join Date
    09-25-2013
    Posts
    25
    Location

    South, South
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G15
    Got a new exhaust manifold at wholesale from dealer and the coolant line as well. Got them installed and the exhaust were not horrible but it was cracked and the coolant line was okay but still fine that i replaced it then. Seems to be running okay. BTW I got a brand new exhaust manifold from the dealer for 187.00 plus tax then an overnight delivery charge (+9.00)

    Mechanic charged me a total of 50.00 to do exhaust manifold, metal coolant hose, and new plugs and wires.

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •