Page 12 of 12 FirstFirst ... 2101112
Results 276 to 279 of 279

Thread: Weber 32/36

  1. #276

    Array
    Status
    Offline
    Join Date
    07-23-2018
    Posts
    88
    Location

    Seattle, WA
    Vehicle

    1988 Dodge Power Ram 50
    Engine

    G54B
    Quote Originally Posted by pacheco2189 View Post
    So I tried the starter fluid and the timing. Still the same. I was doing some other testing and noticed the spark seems weak. Could that be a problem and if so, what could cause it? Also, I know the vacuum system is obsolete but from looking at wiring diagrams the gray control box on the drivers side has like 2 ignition wires that hook into it. Do I need to have that hooked up?
    Weak spark could be due to poor ground or harness connections. Check the battery-to-frame-to-block and the head-to-firewall cables for continuity and clean their contact surfaces. Then check that the coil, resistor block and distributor wiring connections are clean and secure. The coil or ignition igniter in the distributor could be failing, but if it ran fine before the Weber install, I doubt these are causing the starting problem.
    I‘m not sure about the ignition wires to the gray device box. My schematic shows only one, a black and white wire from the resistor block to a choke relay in the box. Like the vacuum lines with the Weber, the harness connections to the box no longer have a purpose. I don’t think it needs to be connected.

    What is the power source for the Weber’s choke? Maybe it’s competing with and killing power to the starting ignition? Look at this thread which describes a loss of spark after a Weber install: http://www.mightyram50.net/vbulletin...spark-to-plugs . See if yours starts after disconnecting the choke wire like rranger found. If it starts, find another power source for the choke. It needs to be energized only when the key is in the "On" position.
    Last edited by FMS88; 01-03-2019 at 10:35 AM.

  2. #277

    Array
    Status
    Offline
    Join Date
    12-05-2015
    Posts
    7
    Location

    Tacoma, WA
    Vehicle

    1987 Dodge Ram 50
    Engine

    G54B
    Still nothing, all grounds are good, all connections are clean and secure. My weber choke is connected to a wire that use to plug into the old carb. I attached pictures of the wiring. I hooked everything back up the same exact way it came of but something seems off.

    Click image for larger version. 

Name:	wire1.jpg 
Views:	26 
Size:	183.5 KB 
ID:	21462Click image for larger version. 

Name:	wire2.jpg 
Views:	24 
Size:	135.5 KB 
ID:	21463Click image for larger version. 

Name:	wire3.jpg 
Views:	24 
Size:	203.9 KB 
ID:	21464

  3. #278

    Array
    Status
    Offline
    Join Date
    07-23-2018
    Posts
    88
    Location

    Seattle, WA
    Vehicle

    1988 Dodge Power Ram 50
    Engine

    G54B
    Hmmm. I'm running out of possibilities. Nothing in the pictures looked wrong. Just to be clear, when you tested for spark, was it at the plugs?

  4. #279

    Array
    Status
    Offline
    Join Date
    11-23-2013
    Posts
    416
    Location

    pa
    Vehicle

    1988 Mitsubishi Mighty Max
    Engine

    G63B
    Put a accel or msd aftermarket coil pack on it . My g63b did the same with weak spark after I rebuilt it . Starts up everytime now .
    MAXDSM

Page 12 of 12 FirstFirst ... 2101112

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •