Results 1 to 7 of 7

Thread: Motor Locked, need to fix today!!!!

  1. #1

    Array
    Status
    Offline
    Join Date
    01-07-2013
    Posts
    41
    Location

    Weaver, AL
    Vehicle

    1987 Mitsubishi Montero

    Motor Locked, need to fix today!!!!

    1987 Raider 2.6 fuel pump was going out and it was skipping real bad. i tached it out thinking it would clear up, floated the lifters and then it was ticking BAD then i pulled up in drive and it just locked up and wouldn't crank back...any ideas of what may have happend? need fixed today gotta have a ride. starter will not even turn the fly wheel...HELPPPPPPPPPPP

  2. #2



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,615
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    sounds like you lost oil pressure or dropped a valve. Very bad. I don't think you are going to get it running today. You can try to rotate the engine backward but I think it's done for.
    Members come and members go, But the board keeps track of them.
    Check out the Fear Monger by
    clicking HERE.

    The MightyRam50 site is sponsored in part by On Site Concrete Inc.

  3. #3

    Array
    Status
    Offline
    Join Date
    01-07-2013
    Posts
    41
    Location

    Weaver, AL
    Vehicle

    1987 Mitsubishi Montero
    just took the plugs out and tryed to turn the motor over and it turned over! but didnt crank!

  4. #4



    Array
    Status
    Offline
    Join Date
    03-20-2011
    Posts
    4,118
    Location

    Pittsburgh, PA
    Vehicle

    1980 Dodge D-50
    Engine

    G54B
    Sounds like the oil pump quit or the pickup plugged up. Pull the valve cover and see if the timing chain is still on the sprocket - I have seen these motors throw the chain if the oiler on the front of the block gets plugged and the chain runs dry.
    Pennyman1
    The best Dodge that Dodge never made
    Living the D-50 lifestyle since 1980

  5. #5

    Array
    Status
    Offline
    Join Date
    12-04-2012
    Posts
    496
    Location

    New Bern, NC
    Vehicle

    1994 Mitsubishi Mighty Max
    Engine

    4G64
    If plugs being out allowed the engine to turn thats usually liquid lock. Either it filled a cylinder with coolant or gas due to a misfire. The 2.6 heads were known to crack between the cylinders also and that could cause liquid lock if your plugs get fouled and it cant be burned. My dad put 3 2.6L engines in our 80s box body voyager van when i was younger for that problem. 3rd was a rod through the block

  6. #6

    Array
    Status
    Offline
    Join Date
    11-06-2012
    Posts
    76
    Location

    Vista CA
    Vehicle

    1991 Mitsubishi Mighty Max
    Engine

    6G72
    I agree, sounds like liquid lock, my type 4 vw did that a couple times when I was running the old dry sump, although that sounds different from your problem. check your plugs and for flooded cylinders maybe?

  7. #7

    Array
    Status
    Offline
    Join Date
    12-03-2012
    Posts
    300
    Location

    Buckingham,VA
    Vehicle

    1992 Mitsubishi Mighty Max
    Engine

    4G67
    Dang dude hope you get it fixed

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •