Results 1 to 12 of 12

Thread: What parts am I missing? 89 2.0 Thanks!

  1. #1

    Array
    Status
    Offline
    Join Date
    11-22-2012
    Posts
    7
    Location

    Scottsdale, AZ
    Vehicle

    1989 Dodge Ram 50
    Engine

    G63B

    What parts am I missing? 89 2.0 Thanks!

    Sorry to have to ask something so soon but I just bought this truck and so far Im clueless. Thanks for your help.

    Anyway, Im trying to find whats missing here. The guy told me its just a hose for the intake but after looking for other ones it seems like it could be more. Im trying to find what parts Im missing so I can go find them. Theres no hose on the bottom either.



  2. #2



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,614
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    There is a plastic hose that runs from the air cleaner to the round connection next to the radiator. No big deal. You don't need it any way. I can't tell if the warm air pipe is there or not. Goes from the manifold to the air cleaner.
    Members come and members go, But the board keeps track of them.
    Check out the Fear Monger by
    clicking HERE.

    The MightyRam50 site is sponsored in part by On Site Concrete Inc.

  3. #3

    Array
    Status
    Offline
    Join Date
    11-22-2012
    Posts
    7
    Location

    Scottsdale, AZ
    Vehicle

    1989 Dodge Ram 50
    Engine

    G63B
    Thanks. Im glad to hear that. Im missing both so maybe Ill just get them. Now I just need to figure out the oil light. PO said probably a bad sensor because it doesnt burn or leak oil. Any truth to that? Im searching for it now so maybe Ill find the answer.

  4. #4



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,614
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    If the oil light is on that can be 2 things. Bad sensor or no oil pressure. If it wan no oil pressure them it would be knocking by now. But you should change the timing belts just so you know there done and in good order. Many times they never get changed and brake on the new owner. We here it all the time.
    Members come and members go, But the board keeps track of them.
    Check out the Fear Monger by
    clicking HERE.

    The MightyRam50 site is sponsored in part by On Site Concrete Inc.

  5. #5

    Array
    Status
    Offline
    Join Date
    07-08-2012
    Posts
    99
    Location

    charleston ar
    Vehicle

    1987 Dodge Ram 50
    if im not mistaken your missing the power steering resivour(sp) and line. should mount on the wheel well right past the charcoal canister. unless its been moved to a different place

  6. #6



    Array
    Status
    Offline
    Join Date
    03-26-2011
    Posts
    1,512
    Location

    Vacaville, CA
    Vehicle

    1989 Mitsubishi Mighty Max
    Engine

    4G63-T
    Most of these trucks dont have power steering, and as said the oil light issue is either low on oil/pressure or the sensor went bad. Its on the oil filter housing under the alternator.
    Josh
    09 BMW 335i E92 Twin turbo
    89 Macrocab 4g63 Turbo swapped & Bagged: Build Thread

  7. #7

    Array
    Status
    Offline
    Join Date
    07-08-2012
    Posts
    99
    Location

    charleston ar
    Vehicle

    1987 Dodge Ram 50
    oh well i didnt know that. i was just going off of what mine has. i guess you learn something every day

  8. #8

    Array
    Status
    Offline
    Join Date
    11-22-2012
    Posts
    7
    Location

    Scottsdale, AZ
    Vehicle

    1989 Dodge Ram 50
    Engine

    G63B
    Yeah it doesnt have power steering. Im going to hit up the junk yard and see what I can find for that. I dont mind no ps for now but it would just make this a better truck. Im still stoked on it.

    Can anyone tell me what causes low oil pressure? The light comes on once it warms up. The PO said it was just a bad sensor but seems like if that was it then the light would always be on.

  9. #9


    Array
    Status
    Offline
    Join Date
    08-31-2011
    Posts
    788
    Location

    Calgary, Alberta, Canada
    Vehicle

    1981 Dodge D-50
    Engine

    Ford V8
    To thin oil weight, If it calls for 10W-30 and someone put in 5w-50 in older engines after it warms up the oil pressure will be low.
    Crank bearings are worn, when the oil gets warm it will flow around the bearing leaking back into the oil pan not getting pushed up to the top of the engine and give low pressure.
    warn oil pump, low oil level,blocked oil passage

    Those are the most common problems other then a bad pressure sensor.

  10. #10



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,614
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    Quote Originally Posted by irishkael View Post
    if im not mistaken your missing the power steering resivour(sp) and line. should mount on the wheel well right past the charcoal canister. unless its been moved to a different place
    Unless it's manual steering. I think it is better my self. More road feel.
    Go out and pick up a mechanical oil pressure gage and put it in/ Then confirm the pressure.
    Members come and members go, But the board keeps track of them.
    Check out the Fear Monger by
    clicking HERE.

    The MightyRam50 site is sponsored in part by On Site Concrete Inc.

  11. #11

    Array
    Status
    Offline
    Join Date
    11-22-2012
    Posts
    7
    Location

    Scottsdale, AZ
    Vehicle

    1989 Dodge Ram 50
    Engine

    G63B
    Thanks guys. Fixed it tonight with an oil change and a new sensor. So glad that fixed it. I did not want to change the oil pump. Makes this all the better buy. Thanks for the manual too.

    Im still debating the power steering. I dont really mind it unless Im coming into a slow speed turn and Im trying to shift up into it. But now that the light is fixed I can drive it a bit stronger. What I really need is a new bed. The front is almost perfect maybe one rock ding. But the bed on one sit is dented in pretty good. Ive thought about getting a new side and welding it back on but I need too many its not worth. So if anyone has a mint bed let me know. Ill figure out a way to ship it. Once I get a good bed I can paint it and really get started.

    Anyhow, thanks again for the help everyone.

  12. #12

    Array
    Status
    Offline
    Join Date
    11-22-2012
    Posts
    7
    Location

    Scottsdale, AZ
    Vehicle

    1989 Dodge Ram 50
    Engine

    G63B
    SO.MANY.TYPOS

    Id fix them but I don't see an edit button.

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •