Results 1 to 3 of 3

Thread: 2.0 oil pump

  1. #1

    Array
    Status
    Offline
    Join Date
    08-05-2012
    Posts
    5
    Location

    Susanville, ca
    Vehicle

    1986 Dodge Ram 50

    2.0 oil pump

    I have a 86 ram 50 with a 2.0 engine. The other day while at idle my engine developed a loud valve train tick. I immediately shut it down. I noticed the oil light was on. Do you think I lost oil pressure due to a pump failure. Has anyone replaced an oil pump on this engine before. Has anyone ran into this before. I have not fired the engine sense. I just don't want to pay time and money to do this job, and find out it wasn't the issue. Any help would be great. Thank you

  2. #2



    Array
    Status
    Offline
    Join Date
    03-20-2011
    Posts
    4,118
    Location

    Pittsburgh, PA
    Vehicle

    1980 Dodge D-50
    Engine

    G54B
    Check the balance shaft belt - it also drives the oil pump and is known to lose teeth and cause oil pressure to drop or vanish. Check your timing belt also - it may need changed also.
    Pennyman1
    The best Dodge that Dodge never made
    Living the D-50 lifestyle since 1980

  3. #3

    Array
    Status
    Offline
    Join Date
    08-05-2012
    Posts
    5
    Location

    Susanville, ca
    Vehicle

    1986 Dodge Ram 50
    I already changed all the belts when I replaced the water pump. I guess one of them could of broke. Things do happen. When I bought the truck the bs belt was already broken. It still ran and held oil pressure. Thanks for your knowledege.

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •