Results 1 to 9 of 9

Thread: Would taking my muffler off create any problems

  1. #1

    Array
    Status
    Offline
    Join Date
    04-22-2012
    Posts
    185
    Location

    Chesapeake, VA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64

    Would taking my muffler off create any problems

    Ive always been one to "stright pipe" my cars and about three days ago i did it to my mighty max. Well today I was driving to my grandparents to stop by and say hi and when i turn into the neighborhood it stutters and shuts off on me. I wouldnt have assumed it was the "stright pipe" but also the day I did it and i went to wawa it did the same thing. Could this be the issue? Maybe there isnt enough backpressure or something idk. Any ideas? Thanks

  2. #2


    Array
    Status
    Offline
    Join Date
    04-04-2011
    Posts
    686
    Location

    Columbus, OH
    Vehicle

    1992 Mitsubishi Mighty Max
    Engine

    Other
    back pressure is bullshit, I raced mine with a straight pipe for years.

    But if you're driving it on the road, you need to be pulled over, towed, and impounded, and put in a cell with a Transgender biker overnight.

  3. #3

    Array
    Status
    Offline
    Join Date
    04-22-2012
    Posts
    185
    Location

    Chesapeake, VA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    i drive it on the road lol its not too loud unless im on it but just crusin it its not much louder than a fart can, but it sounds better =)

  4. #4



    Array
    Status
    Offline
    Join Date
    03-16-2011
    Posts
    3,614
    Location

    Sacramento, CA
    Vehicle

    1979 Dodge D-50
    Engine

    Chevy V6
    Just swap over to a flow master and call it good. It's a straight through shot.
    The shutting off is somthing else.
    Members come and members go, But the board keeps track of them.
    Check out the Fear Monger by
    clicking HERE.

    The MightyRam50 site is sponsored in part by On Site Concrete Inc.

  5. #5

    Array
    Status
    Offline
    Join Date
    04-22-2012
    Posts
    185
    Location

    Chesapeake, VA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    after it cooled off it started right back up, so then i went to drive it home and i got about 8-10 miles up the road then it did it again i let it cool off some and tried to start it it started for like 20 seconds but it was spittin and spudderin really bad so i pushed it into the nearist parking lot and got my bro to pick me up, im going to go up there a little later and see if she starts

  6. #6

    Array
    Status
    Offline
    Join Date
    03-29-2011
    Posts
    363
    Location

    Payette, ID
    Vehicle

    1991 Dodge Ram 50
    Engine

    4G64
    I had the exact same problem when my coil was getting hot and overheating from me taking the ballast resistor off thinking it would make a more powerful spark, you didn't happen to do that did you?

  7. #7

    Array
    Status
    Offline
    Join Date
    03-26-2011
    Posts
    260
    Location

    Savannah, GA
    Vehicle

    1988 Dodge Ram 50
    Engine

    G54B
    If the ballast resistor goes bad this will also happen. It will run until it gets hot then it'll stop. Once it cools it should start again but it wont run very long. When mine went bad I was able to get a universal replacement at advance auto parts.

  8. #8

    Array
    Status
    Offline
    Join Date
    04-22-2012
    Posts
    185
    Location

    Chesapeake, VA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    i did not but i thought it could be my coil getting hot

  9. #9

    Array
    Status
    Offline
    Join Date
    04-22-2012
    Posts
    185
    Location

    Chesapeake, VA
    Vehicle

    1990 Mitsubishi Mighty Max
    Engine

    4G64
    update i feel like a moron i checked all under the hood to see if any sensors were unplugged or anything and i didnt notice it but my dad noticed the wire that goes to the ignition coil has a nut that goes ontop of it turns out mine wasnt there and when the fan would come on it would cause it to mess up i looked all over the engine bay and i swear i didnt notice that i feel stupid lol but at least it was an easy fix =)

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •